summaryrefslogtreecommitdiff
path: root/mysql-test/Makefile.am
diff options
context:
space:
mode:
authorunknown <monty@donna.mysql.com>2001-01-02 14:29:47 +0200
committerunknown <monty@donna.mysql.com>2001-01-02 14:29:47 +0200
commit6cfd66f0f80eaedaf6f22236e49dee919d2f6675 (patch)
tree06f19c5186e8abb542c18b22202664c033b53f4f /mysql-test/Makefile.am
parent0475637d5fa1ff6ac010f4b315a980d5319903d7 (diff)
downloadmariadb-git-6cfd66f0f80eaedaf6f22236e49dee919d2f6675.tar.gz
Fixes to get mysql-test included in the distributions
client/mysqldump.c: Fixed to not use strncasecmp client/mysqlimport.c: Fixed to not use strncasecmp mysql-test/Makefile.am: Changes needed for RPM mysql-test/mysql-test-run.sh: Changes to work with binary installations scripts/make_binary_distribution.sh: Added missing mysql-test files sql-bench/Makefile.am: Changes needed for RPM sql/mysqld.cc: Portability fix support-files/mysql.spec.sh: Added mysql-test to sql-bench
Diffstat (limited to 'mysql-test/Makefile.am')
-rw-r--r--mysql-test/Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/mysql-test/Makefile.am b/mysql-test/Makefile.am
index 88f55690651..20522da3b50 100644
--- a/mysql-test/Makefile.am
+++ b/mysql-test/Makefile.am
@@ -17,11 +17,12 @@
## Process this file with automake to create Makefile.in
-EXTRA_SCRIPTS = mysql-test-run.sh install_test_db.sh
-EXTRA_DIST = $(EXTRA_SCRIPTS)
-testdir = $(prefix)/mysql-test
-test_SCRIPTS = mysql-test-run install_test_db
-CLEANFILES = $(test_SCRIPTS)
+benchdir_root= $(prefix)
+testdir = $(benchdir_root)/mysql-test
+EXTRA_SCRIPTS = mysql-test-run.sh install_test_db.sh
+EXTRA_DIST = $(EXTRA_SCRIPTS)
+test_SCRIPTS = mysql-test-run install_test_db
+CLEANFILES = $(test_SCRIPTS)
dist-hook:
mkdir -p $(distdir)/t $(distdir)/r $(distdir)/include \
@@ -52,7 +53,7 @@ SUFFIXES = .sh
.sh:
@RM@ -f $@ $@-t
@SED@ \
- -e 's!@''benchdir''@!$(benchdir)!g' \
+ -e 's!@''testdir''@!$(testdir)!g' \
-e 's!@''bindir''@!$(bindir)!g' \
-e 's!@''scriptdir''@!$(bindir)!g' \
-e 's!@''prefix''@!$(prefix)!g' \