summaryrefslogtreecommitdiff
path: root/mysql-test/Makefile.am
diff options
context:
space:
mode:
authorDavi Arnaut <davi.arnaut@oracle.com>2010-11-20 12:47:50 -0200
committerDavi Arnaut <davi.arnaut@oracle.com>2010-11-20 12:47:50 -0200
commit8664de2230300967537d75a9ec51d15c400ca36d (patch)
tree2d19b102b6c66d0bcf7bb480f2140a6ffc9da7bb /mysql-test/Makefile.am
parent766db2b52fe28514d47b159b9ec05445bdf36ab9 (diff)
downloadmariadb-git-8664de2230300967537d75a9ec51d15c400ca36d.tar.gz
WL#5665: Removal of the autotools-based build system
The autotools-based build system has been superseded and is being removed in order to ease the maintenance burden on developers tweaking and maintaining the build system. In order to support tools that need to extract the server version, a new file that (only) contains the server version, called VERSION, is introduced. The file contents are human and machine-readable. The format is: MYSQL_VERSION_MAJOR=5 MYSQL_VERSION_MINOR=5 MYSQL_VERSION_PATCH=8 MYSQL_VERSION_EXTRA=-rc The CMake based version extraction in cmake/mysql_version.cmake is changed to extract the version from this file. The configure to CMake wrapper is retained for backwards compatibility and to support the BUILD/ scripts. Also, a new a makefile target show-dist-name that prints the server version is introduced. VERSION: Add top-level version file. cmake/mysql_version.cmake: Get version information from the top-level VERSION file. Do not cache the version components (MAJOR_VERSION, etc). Add MYSQL_RPM_VERSION as a replacement for MYSQL_U_SCORE_VERSION.
Diffstat (limited to 'mysql-test/Makefile.am')
-rw-r--r--mysql-test/Makefile.am150
1 files changed, 0 insertions, 150 deletions
diff --git a/mysql-test/Makefile.am b/mysql-test/Makefile.am
deleted file mode 100644
index 030a4823b36..00000000000
--- a/mysql-test/Makefile.am
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright (C) 2000-2006 MySQL AB, 2008-2009 Sun Microsystems, Inc.
-#
-# This library is free software; you can redistribute it and/or
-# modify it under the terms of the GNU Library General Public
-# License as published by the Free Software Foundation; version 2
-# of the License.
-#
-# This library is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# Library General Public License for more details.
-#
-# You should have received a copy of the GNU Library General Public
-# License along with this library; if not, write to the Free
-# Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
-# MA 02111-1307, USA
-
-## Process this file with automake to create Makefile.in
-
-testroot = $(prefix)
-testdir = $(testroot)/mysql-test
-
-test_SCRIPTS = mtr \
- mysql-test-run \
- mysql-test-run.pl \
- mysql-stress-test.pl
-
-nobase_test_DATA = \
- valgrind.supp \
- lib/v1/mysql-test-run.pl \
- lib/v1/mtr_cases.pl \
- lib/v1/mtr_io.pl \
- lib/v1/mtr_report.pl \
- lib/v1/My/Config.pm \
- lib/v1/mtr_gcov.pl \
- lib/v1/mtr_match.pl \
- lib/v1/mtr_stress.pl \
- lib/v1/ndb_config_1_node.ini \
- lib/v1/ndb_config_2_node.ini \
- lib/v1/mtr_gprof.pl \
- lib/v1/mtr_misc.pl \
- lib/v1/mtr_timer.pl \
- lib/v1/mtr_im.pl \
- lib/v1/mtr_process.pl \
- lib/v1/mtr_unique.pl \
- lib/mtr_cases.pm \
- lib/mtr_gcov.pl \
- lib/mtr_gprof.pl \
- lib/mtr_io.pl \
- lib/mtr_match.pm \
- lib/mtr_misc.pl \
- lib/mtr_process.pl \
- lib/mtr_report.pm \
- lib/mtr_stress.pl \
- lib/mtr_unique.pm \
- lib/My/ConfigFactory.pm \
- lib/My/Config.pm \
- lib/My/Find.pm \
- lib/My/Handles.pm \
- lib/My/Options.pm \
- lib/My/Test.pm \
- lib/My/Platform.pm \
- lib/My/SafeProcess.pm \
- lib/My/File/Path.pm \
- lib/My/SysInfo.pm \
- lib/My/CoreDump.pm \
- lib/My/SafeProcess/Base.pm \
- lib/My/SafeProcess/safe_process.pl
-
-SUBDIRS = lib/My/SafeProcess
-
-EXTRA_DIST = README \
- $(test_SCRIPTS) \
- $(nobase_test_DATA) \
- CMakeLists.txt \
- mtr.out-of-source
-
-
-# List of directories containing test + result files and the
-# related test data files that should be copied
-# If you want to add a new suite, please check DEFAULT_SUITES in
-# mysql-test-run.pl.
-TEST_DIRS = t r include std_data std_data/parts collections \
- std_data/ndb_backup50 std_data/ndb_backup51 \
- std_data/ndb_backup51_data_be std_data/ndb_backup51_data_le \
- std_data/funcs_1 \
- extra/binlog_tests/ extra/rpl_tests \
- suite/binlog suite/binlog/t suite/binlog/r suite/binlog/std_data \
- suite/bugs suite/bugs/data suite/bugs/t suite/bugs/r \
- suite/federated \
- suite/funcs_1 suite/funcs_1/bitdata \
- suite/funcs_1/include suite/funcs_1/lib suite/funcs_1/r \
- suite/funcs_1/t suite/funcs_1/views suite/funcs_1/cursors \
- suite/funcs_1/datadict suite/funcs_1/storedproc suite/funcs_1/triggers \
- suite/funcs_2 suite/funcs_2/charset suite/funcs_2/data \
- suite/funcs_2/include suite/funcs_2/lib suite/funcs_2/r \
- suite/funcs_2/t \
- suite/jp suite/jp/t suite/jp/r suite/jp/std_data suite/jp/include \
- suite/manual/t suite/manual/r \
- suite/ndb_team suite/ndb_team/t suite/ndb_team/r \
- suite/rpl suite/rpl/include suite/rpl/r \
- suite/rpl/t \
- suite/stress/include suite/stress/t suite/stress/r \
- suite/ndb suite/ndb/t suite/ndb/r \
- suite/rpl_ndb suite/rpl_ndb/t suite/rpl_ndb/r \
- suite/parts suite/parts/t suite/parts/r suite/parts/inc \
- suite/innodb suite/innodb/t suite/innodb/r suite/innodb/include \
- suite/engines suite/engines/funcs suite/engines/iuds suite/engines/rr_trx \
- suite/engines/funcs/r suite/engines/funcs/t suite/engines/iuds/r \
- suite/engines/iuds/t suite/engines/rr_trx/include suite/engines/rr_trx/r \
- suite/engines/rr_trx/t \
- suite/sys_vars suite/sys_vars/t suite/sys_vars/inc suite/sys_vars/r \
- suite/perfschema suite/perfschema/t suite/perfschema/r \
- suite/perfschema/include
-
-# Used by dist-hook and install-data-local to copy all
-# test files into either dist or install directory
-install_test_files:
- @if test -z "$(INSTALL_TO_DIR)"; then \
- echo "Set INSTALL_TO_DIR!" && exit 1; \
- fi
- @for dir in $(TEST_DIRS); do \
- from_dir="$(srcdir)/$$dir"; \
- to_dir="$(INSTALL_TO_DIR)/$$dir"; \
- $(mkinstalldirs) "$$to_dir"; \
- for f in `(cd $$from_dir && ls)`; do \
- if test -f "$$from_dir/$$f"; then \
- $(INSTALL_DATA) "$$from_dir/$$f" "$$to_dir/$$f" ; \
- fi; \
- done \
- done
-
-dist-hook:
- $(MAKE) INSTALL_TO_DIR="$(distdir)" install_test_files
-
-install-data-local:
- $(MAKE) INSTALL_TO_DIR="$(DESTDIR)$(testdir)" install_test_files
-
-uninstall-local:
- @RM@ -f -r $(DESTDIR)$(testdir)
-
-# mtr - a shortcut for executing mysql-test-run.pl
-mtr:
- $(RM) -f mtr
- $(LN_S) mysql-test-run.pl mtr
-
-# mysql-test-run - a shortcut for executing mysql-test-run.pl
-mysql-test-run:
- $(RM) -f mysql-test-run
- $(LN_S) mysql-test-run.pl mysql-test-run