summaryrefslogtreecommitdiff
path: root/mysql-test/Makefile.am
diff options
context:
space:
mode:
authorDavi Arnaut <Davi.Arnaut@Sun.COM>2009-06-05 13:55:09 -0300
committerDavi Arnaut <Davi.Arnaut@Sun.COM>2009-06-05 13:55:09 -0300
commit46a4685cdb29ea885ddbec6d500b6c64180706e9 (patch)
tree2acb6489949c4107133b7ffb9d5bbf68112ec17a /mysql-test/Makefile.am
parent9ceb37269d1039b082f90e32e0fab499e475c24d (diff)
downloadmariadb-git-46a4685cdb29ea885ddbec6d500b6c64180706e9.tar.gz
The valgrind suppression file (valgrind.supp) must be added to
a binary distribution of the server as the MTR valgrind option relies on it to silence unmeaningful warnings. mysql-test/Makefile.am: Install valgrind.supp as part of the test suite. Remove reference to inexistent directory.
Diffstat (limited to 'mysql-test/Makefile.am')
-rw-r--r--mysql-test/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/mysql-test/Makefile.am b/mysql-test/Makefile.am
index 5e3582d5e16..7a56584190d 100644
--- a/mysql-test/Makefile.am
+++ b/mysql-test/Makefile.am
@@ -25,6 +25,7 @@ test_SCRIPTS = mtr \
mysql-stress-test.pl
nobase_test_DATA = \
+ valgrind.supp \
lib/v1/mysql-test-run.pl \
lib/v1/mtr_cases.pl \
lib/v1/mtr_io.pl \
@@ -41,7 +42,6 @@ nobase_test_DATA = \
lib/v1/mtr_im.pl \
lib/v1/mtr_process.pl \
lib/v1/mtr_unique.pl \
-\
lib/mtr_cases.pm \
lib/mtr_gcov.pl \
lib/mtr_gprof.pl \
@@ -69,9 +69,8 @@ nobase_test_DATA = \
SUBDIRS = lib/My/SafeProcess
EXTRA_DIST = README \
- valgrind.supp \
$(test_SCRIPTS) \
- $(nobase_test_DATA)
+ $(nobase_test_DATA)
# List of directories containing test + result files and the
# related test data files that should be copied
@@ -93,7 +92,7 @@ TEST_DIRS = t r include std_data std_data/parts collections \
suite/jp suite/jp/t suite/jp/r suite/jp/std_data suite/jp/include \
suite/manual/t suite/manual/r \
suite/ndb_team suite/ndb_team/t suite/ndb_team/r \
- suite/rpl suite/rpl/data suite/rpl/include suite/rpl/r \
+ suite/rpl suite/rpl/include suite/rpl/r \
suite/rpl/t \
suite/stress/include suite/stress/t suite/stress/r \
suite/ndb suite/ndb/t suite/ndb/r \