summaryrefslogtreecommitdiff
path: root/mysql-test/Makefile.am
diff options
context:
space:
mode:
authorSergei Golubchik <sergii@pisem.net>2010-08-17 11:14:46 +0400
committerSergei Golubchik <sergii@pisem.net>2010-08-17 11:14:46 +0400
commit8da7be63027403c5b82eda378842142cdcbad95c (patch)
treeb7dca1ad91ae877215e49ddf87d3fbc52544e546 /mysql-test/Makefile.am
parentb87a73773913ebdcfdacb2d8b8704958bc0e93f2 (diff)
downloadmariadb-git-8da7be63027403c5b82eda378842142cdcbad95c.tar.gz
generalization of mtr to support suite.pm extensions:
* no automatic --loose-skip-innodb added by mtr based on the test name. instead loose-skip-innodb is now in the default_mysqld.cnf * have_innodb_plugin.inc is changed to give a verbose "skip" message (instead of "require: true") * My::Suite class. It's support in mtr, and everywhere * support for suite.pm * when sorting tests, take combinations into account * support for SUITENAME_COMBINATIONS * no special treatment for innodb_plugin in mtr_cases.pm * two special pre-created config groups: ENV and OPT * allow option names to start from # * allow magic option to have an argument * remove dead code * fix @-substitution to works as expected * new processes take the value of $opt_verbose automatically, no need to pass it to a constructor * innodb_plugin suite uses suite.pm and combinations file to test as much as possible (innodb plugin, xtradb plugin, xtradb static - whatever available) * besides test-master.opt and test-slave.opt a test.opt file is also loaded, both for master and slave * .opt files for all included files are loaded too * progress report in the xterm titlebar
Diffstat (limited to 'mysql-test/Makefile.am')
-rw-r--r--mysql-test/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/mysql-test/Makefile.am b/mysql-test/Makefile.am
index 4ea634688fe..7a0d4c2d6fc 100644
--- a/mysql-test/Makefile.am
+++ b/mysql-test/Makefile.am
@@ -63,13 +63,14 @@ nobase_test_DATA = \
lib/My/SafeProcess.pm \
lib/My/File/Path.pm \
lib/My/SysInfo.pm \
+ lib/My/Suite.pm \
lib/My/CoreDump.pm \
lib/My/SafeProcess/Base.pm \
lib/My/SafeProcess/safe_process.pl
SUBDIRS = lib/My/SafeProcess
-EXTRA_DIST = README \
+EXTRA_DIST = README README.suites \
$(test_SCRIPTS) \
$(nobase_test_DATA)
@@ -101,7 +102,7 @@ TEST_DIRS = t r include std_data std_data/parts collections \
suite/ndb suite/ndb/t suite/ndb/r \
suite/rpl_ndb suite/rpl_ndb/t suite/rpl_ndb/r \
suite/parts suite/parts/t suite/parts/r suite/parts/inc \
- suite/pbxt/t suite/pbxt/r \
+ suite/pbxt/t suite/pbxt/r suite/pbxt \
suite/innodb suite/innodb/t suite/innodb/r suite/innodb/include \
suite/innodb_plugin suite/innodb_plugin/t suite/innodb_plugin/r suite/innodb_plugin/include \
suite/percona \