summaryrefslogtreecommitdiff
path: root/mysql-test/Makefile.am
diff options
context:
space:
mode:
authorserg@serg.mylan <>2005-03-09 14:09:06 +0100
committerserg@serg.mylan <>2005-03-09 14:09:06 +0100
commit956682de1a15d974e6ad034218bb14fa1d17a370 (patch)
tree4625d7f51e27bb495a5f571cfcad95a20d34e4a9 /mysql-test/Makefile.am
parentc49928447df13564ad8c657bf01d8010c9732d0c (diff)
parentc64b47fc0e4e834b0d7a449f6f948893e790e902 (diff)
downloadmariadb-git-956682de1a15d974e6ad034218bb14fa1d17a370.tar.gz
merged
Diffstat (limited to 'mysql-test/Makefile.am')
-rw-r--r--mysql-test/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/mysql-test/Makefile.am b/mysql-test/Makefile.am
index 6bcd0715ccd..294c135bcf3 100644
--- a/mysql-test/Makefile.am
+++ b/mysql-test/Makefile.am
@@ -20,12 +20,14 @@
if HAVE_NDBCLUSTER_DB
SUBDIRS = ndb
DIST_SUBDIRS=ndb
+USE_NDBCLUSTER=\"--ndbcluster\"
else
# If one uses automake conditionals, automake will automatically
# include all possible branches to DIST_SUBDIRS goal.
# Reset DIST_SUBDIRS if we don't use NDB
SUBDIRS=
DIST_SUBDIRS=
+USE_NDBCLUSTER=\"\"
endif
benchdir_root= $(prefix)
@@ -103,6 +105,7 @@ SUFFIXES = .sh
-e 's!@''MYSQL_TCP_PORT''@!@MYSQL_TCP_PORT@!' \
-e 's!@''MYSQL_NO_DASH_VERSION''@!@MYSQL_NO_DASH_VERSION@!' \
-e 's!@''MYSQL_SERVER_SUFFIX''@!@MYSQL_SERVER_SUFFIX@!' \
+ -e 's!@''USE_NDBCLUSTER''@!$(USE_NDBCLUSTER)!g' \
$< > $@-t
@CHMOD@ +x $@-t
@MV@ $@-t $@