summaryrefslogtreecommitdiff
path: root/mysql-test/Makefile.am
diff options
context:
space:
mode:
authorunknown <joerg@trift-lap.fambruehe>2007-04-26 17:11:33 +0200
committerunknown <joerg@trift-lap.fambruehe>2007-04-26 17:11:33 +0200
commit246316e76de46bdb726ea430ad8dedc2eaa9e17e (patch)
tree24ee23cf3e00208526f0654d43d6cf628b530e2a /mysql-test/Makefile.am
parent3331f184c0b476b50392382d2df42719158d2ad1 (diff)
parent64c0392a9e1dd003b868f2d11d7aa9ad401bf8eb (diff)
downloadmariadb-git-246316e76de46bdb726ea430ad8dedc2eaa9e17e.tar.gz
Merge trift-lap.fambruehe:/MySQL/M50/push-5.0
into trift-lap.fambruehe:/MySQL/M51/push-5.1 mysql-test/Makefile.am: Auto merged scripts/mysql_install_db.sh: Auto merged scripts/mysql_system_tables.sql: Auto merged scripts/mysql_system_tables_data.sql: Auto merged sql/item_subselect.h: Auto merged storage/ndb/include/ndbapi/Ndb.hpp: Auto merged storage/ndb/src/kernel/blocks/dbdict/Dbdict.cpp: Auto merged storage/ndb/test/ndbapi/testScanFilter.cpp: Auto merged BitKeeper/deleted/.del-mysql.sln~76a9ff1e793b3547: No need to propagate 5.0 changes into a 5.1 file which is deleted anyway. Makefile.am: Add "funcs_1" and "funcs_2" to the 5.1 version of the "test-bt" target. storage/ndb/src/ndbapi/NdbImpl.hpp: Manual merge from 5.0.40
Diffstat (limited to 'mysql-test/Makefile.am')
-rw-r--r--mysql-test/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/mysql-test/Makefile.am b/mysql-test/Makefile.am
index 839dc434e46..1e9371e5bf2 100644
--- a/mysql-test/Makefile.am
+++ b/mysql-test/Makefile.am
@@ -24,7 +24,7 @@ benchdir_root= $(prefix)
testdir = $(benchdir_root)/mysql-test
EXTRA_SCRIPTS = mysql-test-run-shell.sh install_test_db.sh \
valgrind.supp $(PRESCRIPTS)
-EXTRA_DIST = $(EXTRA_SCRIPTS)
+EXTRA_DIST = $(EXTRA_SCRIPTS) suite
GENSCRIPTS = mysql-test-run-shell install_test_db mtr mysql-test-run
PRESCRIPTS = mysql-test-run.pl
test_SCRIPTS = $(GENSCRIPTS) $(PRESCRIPTS)
@@ -71,6 +71,7 @@ dist-hook:
$(INSTALL_DATA) $(srcdir)/std_data/ndb_backup50/BACKUP* $(distdir)/std_data/ndb_backup50
$(INSTALL_DATA) $(srcdir)/std_data/ndb_backup51/BACKUP* $(distdir)/std_data/ndb_backup51
$(INSTALL_DATA) $(srcdir)/lib/*.pl $(distdir)/lib
+ -rm -rf `find $(distdir)/suite -type d -name SCCS`
install-data-local:
$(mkinstalldirs) \
@@ -112,6 +113,12 @@ install-data-local:
$(INSTALL_DATA) $(srcdir)/std_data/ndb_backup50/BACKUP* $(DESTDIR)$(testdir)/std_data/ndb_backup50
$(INSTALL_DATA) $(srcdir)/std_data/ndb_backup51/BACKUP* $(DESTDIR)$(testdir)/std_data/ndb_backup51
$(INSTALL_DATA) $(srcdir)/lib/*.pl $(DESTDIR)$(testdir)/lib
+ for f in `(cd $(srcdir); find suite -type f | grep -v SCCS)`; \
+ do \
+ d=$(DESTDIR)$(testdir)/`dirname $$f`; \
+ mkdir -p $$d ; \
+ $(INSTALL_DATA) $(srcdir)/$$f $$d ; \
+ done
uninstall-local:
@RM@ -f -r $(DESTDIR)$(testdir)