summaryrefslogtreecommitdiff
path: root/mysql-test/ndb/Makefile.am
diff options
context:
space:
mode:
authorunknown <tomas@poseidon.ndb.mysql.com>2004-11-10 16:05:28 +0000
committerunknown <tomas@poseidon.ndb.mysql.com>2004-11-10 16:05:28 +0000
commitb6ed85ba5a884145723058344571b682de3f4c9e (patch)
tree364c6c40f694a800ae1d5172a69490ab4871f9c9 /mysql-test/ndb/Makefile.am
parenta12d6fd6a7277f71ee8857c7b8f00c4e574bc752 (diff)
downloadmariadb-git-b6ed85ba5a884145723058344571b682de3f4c9e.tar.gz
added configure switch for ndb port number
added new variable for ndb port 1186 changed meaning of ndb_port_base to be default tcp port setting changed to use split between port and port_base for ndbcluster so that ndb_port and ndb_port_base are propagated to startscript for ndbcluster added larger space to pid print moved readAndExecute out of CommandInterpreter to avoid linking lib with readline added c-api to Ndb_mgmclient pass also ndb_port to make acinclude.m4: added configure switch for ndb port number configure.in: added new variable for ndb port 1186 changed meaning of ndb_port_base to be default tcp port setting mysql-test/mysql-test-run.sh: changed to use split between port and port_base for ndbcluster mysql-test/ndb/Makefile.am: so that ndb_port and ndb_port_base are propagated to startscript for ndbcluster mysql-test/ndb/ndbcluster.sh: so that ndb_port and ndb_port_base are propagated to startscript for ndbcluster ndb/src/common/mgmcommon/LocalConfig.cpp: so that ndb_port and ndb_port_base are propagated to startscript for ndbcluster ndb/src/common/mgmcommon/Makefile.am: so that ndb_port and ndb_port_base are propagated to startscript for ndbcluster ndb/src/common/mgmcommon/NdbConfig.c: added larger space to pid print ndb/src/mgmclient/CommandInterpreter.cpp: moved readAndExecute out of CommandInterpreter to avoid linking lib with readline added c-api to Ndb_mgmclient ndb/src/mgmclient/main.cpp: moved readAndExecute out of CommandInterpreter to avoid linking lib with readline ndb/src/mgmclient/ndb_mgmclient.hpp: moved readAndExecute out of CommandInterpreter to avoid linking lib with readline ndb/src/mgmsrv/ConfigInfo.cpp: moved readAndExecute out of CommandInterpreter to avoid linking lib with readline ndb/src/mgmsrv/Makefile.am: pass also ndb_port to make
Diffstat (limited to 'mysql-test/ndb/Makefile.am')
-rw-r--r--mysql-test/ndb/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/mysql-test/ndb/Makefile.am b/mysql-test/ndb/Makefile.am
index 3ed222344a6..502ccee099e 100644
--- a/mysql-test/ndb/Makefile.am
+++ b/mysql-test/ndb/Makefile.am
@@ -13,6 +13,8 @@ SUFFIXES = .sh
.sh:
@RM@ -f $@ $@-t
@SED@ \
+ -e 's!@''ndb_port''@!$(ndb_port)!g' \
+ -e 's!@''ndb_port_base''@!$(ndb_port_base)!g' \
-e 's!@''ndbbindir''@!$(ndbbindir)!g' \
-e 's!@''ndbtoolsdir''@!$(ndbtoolsdir)!g' \
$< > $@-t