summaryrefslogtreecommitdiff
path: root/mysys/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <vvaintroub@koala>2009-12-07 02:16:05 +0100
committerVladislav Vaintroub <vvaintroub@koala>2009-12-07 02:16:05 +0100
commit9fcef3c45bd936b7da20679a1bb160c22f4945ff (patch)
treebe34c035a12551aff48f3bcdb4fcbf4754f8b3f0 /mysys/CMakeLists.txt
parent2e6270311467f557a424a15b03d8d52c5b0ea92d (diff)
downloadmariadb-git-9fcef3c45bd936b7da20679a1bb160c22f4945ff.tar.gz
On Linux, support -Wl,--no-undefined (only client shared library)
and --Wl,--as-needed (all shared modules). The later will remove unused dependencies (also from gcc and C++ runtime)
Diffstat (limited to 'mysys/CMakeLists.txt')
-rwxr-xr-xmysys/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/mysys/CMakeLists.txt b/mysys/CMakeLists.txt
index 2264b99e75b..06d053f1902 100755
--- a/mysys/CMakeLists.txt
+++ b/mysys/CMakeLists.txt
@@ -63,5 +63,6 @@ IF(UNIX)
SET(MYSYS_SOURCES ${MYSYS_SOURCES} my_port.c)
ENDIF()
ADD_CONVENIENCE_LIBRARY(mysys ${MYSYS_SOURCES})
-TARGET_LINK_LIBRARIES(mysys dbug strings ${ZLIB_LIBRARY})
+TARGET_LINK_LIBRARIES(mysys dbug strings ${ZLIB_LIBRARY}
+ ${LIBNLS} ${LIBM})
DTRACE_INSTRUMENT(mysys)