summaryrefslogtreecommitdiff
path: root/mysys/CMakeLists.txt
diff options
context:
space:
mode:
authorkent@mysql.com/kent-amd64.(none) <>2007-08-03 21:51:37 +0200
committerkent@mysql.com/kent-amd64.(none) <>2007-08-03 21:51:37 +0200
commita6d082f36de35794006fd7bcb5495eeaf2dd7e82 (patch)
treee1463cc69b98560699aa561754652f5db4e1e3a2 /mysys/CMakeLists.txt
parent52f71ecc677825126699f3d682a62494a2259506 (diff)
downloadmariadb-git-a6d082f36de35794006fd7bcb5495eeaf2dd7e82.tar.gz
CMakeLists.txt, README, configure.js
Several adjustments to make client libraries pass the link test on both win32 and winx64, Visual Studio 2003 and 2005 (bug#30118)
Diffstat (limited to 'mysys/CMakeLists.txt')
-rwxr-xr-xmysys/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/mysys/CMakeLists.txt b/mysys/CMakeLists.txt
index 4c11b57d736..8aaf0b5f00f 100755
--- a/mysys/CMakeLists.txt
+++ b/mysys/CMakeLists.txt
@@ -13,7 +13,6 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
-SET(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -DSAFEMALLOC -DSAFE_MUTEX")
SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -DSAFEMALLOC -DSAFE_MUTEX")
# Only the server link with this library, the client libraries and the client
@@ -21,7 +20,7 @@ SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -DSAFEMALLOC -DSAFE_MUTEX")
# So we only need to create one version of this library, with the "static"
# Thread Local Storage model.
-INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/zlib ${CMAKE_SOURCE_DIR}/include ${CMAKE_SOURCE_DIR}/mysys )
+INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/zlib ${CMAKE_SOURCE_DIR}/include ${CMAKE_SOURCE_DIR}/mysys)
ADD_LIBRARY(mysys array.c charset-def.c charset.c checksum.c default.c default_modify.c
errors.c hash.c list.c md5.c mf_brkhant.c mf_cache.c mf_dirname.c mf_fn_ext.c