summaryrefslogtreecommitdiff
path: root/mysys/Makefile.am
diff options
context:
space:
mode:
authorsasha@mysql.sashanet.com <>2001-11-03 16:54:00 -0700
committersasha@mysql.sashanet.com <>2001-11-03 16:54:00 -0700
commitb00eee622e6d7eb2de56f7c4f61ae75faf95b4dc (patch)
tree8abf01e56458b77f0e836d8f72481d71cc846b68 /mysys/Makefile.am
parentf3f5a55c5e4ef61b9351612dbe997316a1a66dc0 (diff)
downloadmariadb-git-b00eee622e6d7eb2de56f7c4f61ae75faf95b4dc.tar.gz
more work on IO_CACHE
portability fixes for systems with broken syscalls that do not interrupt on a signal temporary commit - will not be pushed, need to sync up
Diffstat (limited to 'mysys/Makefile.am')
-rw-r--r--mysys/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/mysys/Makefile.am b/mysys/Makefile.am
index 1797d306254..d28ef1364c6 100644
--- a/mysys/Makefile.am
+++ b/mysys/Makefile.am
@@ -95,6 +95,10 @@ test_vsnprintf: my_vsnprintf.c $(LIBRARIES)
$(CP) $(srcdir)/my_vsnprintf.c test_vsnprintf.c
$(LINK) $(FLAGS) -DMAIN ./test_vsnprintf.c $(LDADD) $(LIBS)
$(RM) -f test_vsnprintf.*
+test_io_cache: mf_iocache.c $(LIBRARIES)
+ $(CP) $(srcdir)/mf_iocache.c test_io_cache.c
+ $(LINK) $(FLAGS) -DMAIN ./test_io_cache.c $(LDADD) $(LIBS)
+ $(RM) -f test_io_cache.*
test_dir: test_dir.c $(LIBRARIES)
$(LINK) $(FLAGS) -DMAIN $(srcdir)/test_dir.c $(LDADD) $(LIBS)