summaryrefslogtreecommitdiff
path: root/mysys/Makefile.am
diff options
context:
space:
mode:
authorunknown <konstantin@mysql.com>2005-03-26 01:21:52 +0300
committerunknown <konstantin@mysql.com>2005-03-26 01:21:52 +0300
commit3fd639493aea5c340acc2e28617e8d917d54ff7d (patch)
tree9ac46b7e6cf08e07fbf355f33e45cc2dcc24d17a /mysys/Makefile.am
parent0310e2a770680593de3b4724d08d6836455b3d91 (diff)
downloadmariadb-git-3fd639493aea5c340acc2e28617e8d917d54ff7d.tar.gz
A fix for Bug#8226 "Cannot connect via shared memory":
provide created shared memory objects with proper access rights to make them usable when client and server are running under different accounts. Post review fixes. VC++Files/mysys/mysys.dsp: Add my_windac.c to mysys.lib include/my_sys.h: Declarations for SECURITY_ATTRIBUTES create/destroy functions. mysys/Makefile.am: Add my_windac.c to the list of compiled files. sql-common/client.c: Lower requested access rights for events as the server won't provide clients with ALL access in order to prevent denial of service attack. sql/mysqld.cc: Set proper security attributes for the kernel objects to make them usable when mysqld is running as a Windows service.
Diffstat (limited to 'mysys/Makefile.am')
-rw-r--r--mysys/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/mysys/Makefile.am b/mysys/Makefile.am
index 3ffeeab0411..3ae9c05bff5 100644
--- a/mysys/Makefile.am
+++ b/mysys/Makefile.am
@@ -53,7 +53,7 @@ libmysys_a_SOURCES = my_init.c my_getwd.c mf_getdate.c \
my_net.c my_semaphore.c my_port.c my_sleep.c \
charset.c charset-def.c my_bitmap.c my_bit.c md5.c \
my_gethostbyname.c rijndael.c my_aes.c sha1.c \
- my_handler.c my_netware.c
+ my_handler.c my_netware.c my_windac.c
EXTRA_DIST = thr_alarm.c thr_lock.c my_pthread.c my_thr_init.c \
thr_mutex.c thr_rwlock.c
libmysys_a_LIBADD = @THREAD_LOBJECTS@