summaryrefslogtreecommitdiff
path: root/mysys/Makefile.am
diff options
context:
space:
mode:
authorunknown <guilhem@gbichot3.local>2006-11-16 22:53:53 +0100
committerunknown <guilhem@gbichot3.local>2006-11-16 22:53:53 +0100
commit6691ce30ecd82baf9877242c078a5e1d12a78369 (patch)
treed246b44cb83bb0d0cb69c9d9f68a46cde10f35b7 /mysys/Makefile.am
parent9a06c5023676d3750e54c5ef91e5b7ca4feb0fea (diff)
downloadmariadb-git-6691ce30ecd82baf9877242c078a5e1d12a78369.tar.gz
Maria - WL#3134 Key cache to Page cache conversion
Moving the test_pagecache_ tests from mysys to unittest/mysys. Means fixing includes to work with the new directory, some Makefile.am editing, replacing memset() with bfill(). test_page_cache_*.c renamed to mf_pagecache_*-t.c (-t is the standard suffix for tests in the mytap protocol). Also added plan() and exit_status() calls to tests. Sanja, I put some TODOs for you at the start of mf_pagecache_*.c unittest/mysys/test_file.h: Rename: mysys/test_file.h -> unittest/mysys/test_file.h mysys/Makefile.am: pagecache test files move to top/unittest/mysys mysys/mf_pagecache.c: my_bit.h needed to compile. unittest/mysys/Makefile.am: INCLUDES is a better place for includes than AM_CPPFLAGS (the latter get overriden by prog_CPPFLAGS, which is not desirable here). Adding pagecache's test programs (moved from mysys); test_pagecache_* has been renamed to mf_pagecache*-t (-t is the required suffix for test executables in the mytap framework). unittest/mysys/mf_pagecache_consist.c: fixing includes to work with the new directory. The test must return an exit code informing if any part failed. TODOs for Sanja. unittest/mysys/mf_pagecache_single.c: fixing includes to work with new directory. adding a plan() to account for the number of tests. Adding exit_status() to tell how many tests failed. memset() was giving a compilation warning (implicit declaration etc), properly due to me removing stdio.h etc, so I replaced it with bfill(). TODOs for Sanja. unittest/mysys/test_file.c: moved from mysys (piece of the page cache tests) and includes fixed.
Diffstat (limited to 'mysys/Makefile.am')
-rw-r--r--mysys/Makefile.am55
1 files changed, 0 insertions, 55 deletions
diff --git a/mysys/Makefile.am b/mysys/Makefile.am
index 2f8b34dc301..4d9570febbd 100644
--- a/mysys/Makefile.am
+++ b/mysys/Makefile.am
@@ -130,61 +130,6 @@ test_base64$(EXEEXT): base64.c $(LIBRARIES)
$(LINK) $(FLAGS) -DMAIN ./test_base64.c $(LDADD) $(LIBS)
$(RM) -f ./test_base64.c
-test_mf_pagecache.o: mf_pagecache.c ../include/pagecache.h $(LIBRARIES)
- $(CP) $(srcdir)/mf_pagecache.c test_mf_pagecache.c
- $(COMPILE) $(FLAGS) -DPAGECACHE_DEBUG -DEXTRA_DEBUG -c test_mf_pagecache.c
-
-test_file.o: test_file.c test_file.h
- $(COMPILE) $(FLAGS) -DPAGECACHE_DEBUG -DEXTRA_DEBUG -c test_file.c
-
-test_pagecache_single1k$(EXEEXT): test_pagecache_single.c test_mf_pagecache.o ../unittest/mytap/tap.o test_file.o $(LIBRARIES)
- $(LINK) $(FLAGS) -DMAIN -DPAGECACHE_DEBUG -DPAGE_SIZE=1024 -DEXTRA_DEBUG $(srcdir)/test_pagecache_single.c test_mf_pagecache.o ../unittest/mytap/tap.o test_file.o $(LDADD) $(LIBS)
-
-test_pagecache_single8k$(EXEEXT): test_pagecache_single.c test_mf_pagecache.o ../unittest/mytap/tap.o test_file.o $(LIBRARIES)
- $(LINK) $(FLAGS) -DMAIN -DPAGECACHE_DEBUG -DPAGE_SIZE=8192 -DEXTRA_DEBUG $(srcdir)/test_pagecache_single.c test_mf_pagecache.o ../unittest/mytap/tap.o test_file.o $(LDADD) $(LIBS)
-
-test_pagecache_single64k$(EXEEXT): test_pagecache_single.c test_mf_pagecache.o ../unittest/mytap/tap.o test_file.o $(LIBRARIES)
- $(LINK) $(FLAGS) -DMAIN -DPAGECACHE_DEBUG -DPAGE_SIZE=65536 -DEXTRA_DEBUG $(srcdir)/test_pagecache_single.c test_mf_pagecache.o ../unittest/mytap/tap.o test_file.o $(LDADD) $(LIBS)
-
-test_pagecache_single: test_pagecache_single1k$(EXEEXT) test_pagecache_single8k$(EXEEXT) test_pagecache_single64k$(EXEEXT)
- ./test_pagecache_single64k$(EXEEXT)
- ./test_pagecache_single8k$(EXEEXT)
- ./test_pagecache_single1k$(EXEEXT)
-
-test_pagecache_consist1k$(EXEEXT): test_pagecache_consist.c test_mf_pagecache.o ../unittest/mytap/tap.o $(LIBRARIES)
- $(LINK) $(FLAGS) -DMAIN -DPAGECACHE_DEBUG -DPAGE_SIZE=1024 -DEXTRA_DEBUG $(srcdir)/test_pagecache_consist.c test_mf_pagecache.o ../unittest/mytap/tap.o $(LDADD) $(LIBS)
-
-test_pagecache_consist64k$(EXEEXT): test_pagecache_consist.c test_mf_pagecache.o ../unittest/mytap/tap.o $(LIBRARIES)
- $(LINK) $(FLAGS) -DMAIN -DPAGECACHE_DEBUG -DPAGE_SIZE=65536 -DEXTRA_DEBUG $(srcdir)/test_pagecache_consist.c test_mf_pagecache.o ../unittest/mytap/tap.o $(LDADD) $(LIBS)
-
-test_pagecache_consist1kHC$(EXEEXT): test_pagecache_consist.c test_mf_pagecache.o ../unittest/mytap/tap.o $(LIBRARIES)
- $(LINK) $(FLAGS) -DMAIN -DPAGECACHE_DEBUG -DTEST_HIGH_CONCURENCY -DPAGE_SIZE=1024 -DEXTRA_DEBUG $(srcdir)/test_pagecache_consist.c test_mf_pagecache.o ../unittest/mytap/tap.o $(LDADD) $(LIBS)
-
-test_pagecache_consist64kHC$(EXEEXT): test_pagecache_consist.c test_mf_pagecache.o ../unittest/mytap/tap.o $(LIBRARIES)
- $(LINK) $(FLAGS) -DMAIN -DPAGECACHE_DEBUG -DTEST_HIGH_CONCURENCY -DPAGE_SIZE=65536 -DEXTRA_DEBUG $(srcdir)/test_pagecache_consist.c test_mf_pagecache.o ../unittest/mytap/tap.o $(LDADD) $(LIBS)
-
-test_pagecache_consist1kRD$(EXEEXT): test_pagecache_consist.c test_mf_pagecache.o ../unittest/mytap/tap.o $(LIBRARIES)
- $(LINK) $(FLAGS) -DMAIN -DPAGECACHE_DEBUG -DTEST_READERS -DPAGE_SIZE=1024 -DEXTRA_DEBUG $(srcdir)/test_pagecache_consist.c test_mf_pagecache.o ../unittest/mytap/tap.o $(LDADD) $(LIBS)
-
-test_pagecache_consist64kRD$(EXEEXT): test_pagecache_consist.c test_mf_pagecache.o ../unittest/mytap/tap.o $(LIBRARIES)
- $(LINK) $(FLAGS) -DMAIN -DPAGECACHE_DEBUG -DTEST_READERS -DPAGE_SIZE=65536 -DEXTRA_DEBUG $(srcdir)/test_pagecache_consist.c test_mf_pagecache.o ../unittest/mytap/tap.o $(LDADD) $(LIBS)
-
-test_pagecache_consist1kWR$(EXEEXT): test_pagecache_consist.c test_mf_pagecache.o ../unittest/mytap/tap.o $(LIBRARIES)
- $(LINK) $(FLAGS) -DMAIN -DPAGECACHE_DEBUG -DTEST_WRITERS -DPAGE_SIZE=1024 -DEXTRA_DEBUG $(srcdir)/test_pagecache_consist.c test_mf_pagecache.o ../unittest/mytap/tap.o $(LDADD) $(LIBS)
-
-test_pagecache_consist64kWR$(EXEEXT): test_pagecache_consist.c test_mf_pagecache.o ../unittest/mytap/tap.o $(LIBRARIES)
- $(LINK) $(FLAGS) -DMAIN -DPAGECACHE_DEBUG -DTEST_WRITERS -DPAGE_SIZE=65536 -DEXTRA_DEBUG $(srcdir)/test_pagecache_consist.c test_mf_pagecache.o ../unittest/mytap/tap.o $(LDADD) $(LIBS)
-
-test_pagecache_consist: test_pagecache_consist1k$(EXEEXT) test_pagecache_consist64k$(EXEEXT) test_pagecache_consist1kHC$(EXEEXT) test_pagecache_consist64kHC$(EXEEXT) test_pagecache_consist1kRD$(EXEEXT) test_pagecache_consist64kRD$(EXEEXT) test_pagecache_consist1kWR$(EXEEXT) test_pagecache_consist64kWR$(EXEEXT)
- ./test_pagecache_consist1k$(EXEEXT)
- ./test_pagecache_consist64k$(EXEEXT)
- ./test_pagecache_consist1kHC$(EXEEXT)
- ./test_pagecache_consist64kHC$(EXEEXT)
- ./test_pagecache_consist1kRD$(EXEEXT)
- ./test_pagecache_consist64kRD$(EXEEXT)
- ./test_pagecache_consist1kWR$(EXEEXT)
- ./test_pagecache_consist64kWR$(EXEEXT)
-
# Don't update the files from bitkeeper
%::SCCS/s.%