summaryrefslogtreecommitdiff
path: root/mysys/Makefile.am
diff options
context:
space:
mode:
authorunknown <sasha@mysql.sashanet.com>2001-04-02 19:01:15 -0600
committerunknown <sasha@mysql.sashanet.com>2001-04-02 19:01:15 -0600
commitae5b950c4dd81daa0e03847905f3f38b4ef8b409 (patch)
treecc9f61f71666e0b4b3f190526b4d8f1641274e5d /mysys/Makefile.am
parent3a3e8e99d5ba9a4659617d40554677d34053a7e7 (diff)
downloadmariadb-git-ae5b950c4dd81daa0e03847905f3f38b4ef8b409.tar.gz
got --with-other-libc to work, finally
configure.in: updates for --with-other-libc heap/Makefile.am: --with-other-libc libmysql/Makefile.shared: --with-other-libc mysys/Makefile.am: --with-other-libc regex/Makefile.am: --with-other-libc sql/Makefile.am: --with-other-libc strings/Makefile.am: --with-other-libc
Diffstat (limited to 'mysys/Makefile.am')
-rw-r--r--mysys/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/mysys/Makefile.am b/mysys/Makefile.am
index 6674132bdca..bc7720aef74 100644
--- a/mysys/Makefile.am
+++ b/mysys/Makefile.am
@@ -73,7 +73,7 @@ OMIT_DEPENDENCIES = pthread.h stdio.h __stdio.h stdlib.h __stdlib.h math.h\
cdefs.h machdep.h signal.h __signal.h util.h
# I hope this always does the right thing. Otherwise this is only test programs
-FLAGS=$(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS)
+FLAGS=$(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) @NOINST_LDFLAGS@
#
# The CP .. RM stuff is to avoid problems with some compilers (like alpha ccc)
@@ -81,17 +81,17 @@ FLAGS=$(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS)
#
test_thr_alarm: thr_alarm.c $(LIBRARIES)
- $(CP) $(srcdir)/thr_alarm.c ./test_thr_alarm.c
- $(LINK) $(FLAGS) -DMAIN ./test_thr_alarm.c $(LDADD) $(LIBS)
+ $(CP) -f $(srcdir)/thr_alarm.c ./test_thr_alarm.c
+ $(LINK) $(FLAGS) -DMAIN ./test_thr_alarm.c $(LDADD) $(LIBS)
$(RM) -f ./test_thr_alarm.*
test_thr_lock: thr_lock.c $(LIBRARIES)
- $(CP) $(srcdir)/thr_lock.c test_thr_lock.c
- $(LINK) $(FLAGS) -DMAIN ./test_thr_lock.c $(LDADD) $(LIBS)
+ $(CP) -f $(srcdir)/thr_lock.c test_thr_lock.c
+ $(LINK) $(FLAGS) -DMAIN ./test_thr_lock.c $(LDADD) $(LIBS)
$(RM) -f ./test_thr_lock.*
test_vsnprintf: my_vsnprintf.c $(LIBRARIES)
- $(CP) $(srcdir)/my_vsnprintf.c test_vsnprintf.c
+ $(CP) -f $(srcdir)/my_vsnprintf.c test_vsnprintf.c
$(LINK) $(FLAGS) -DMAIN ./test_vsnprintf.c $(LDADD) $(LIBS)
$(RM) -f test_vsnprintf.*
@@ -101,7 +101,7 @@ test_dir: test_dir.c $(LIBRARIES)
test_charset: test_charset.c $(LIBRARIES)
$(LINK) $(FLAGS) -DMAIN $(srcdir)/test_charset.c $(LDADD) $(LIBS)
-test_hash: test_hash.c $(LIBRARIES)
+testhash: testhash.c $(LIBRARIES)
$(LINK) $(FLAGS) -DMAIN $(srcdir)/test_dir.c $(LDADD) $(LIBS)
# Don't update the files from bitkeeper