summaryrefslogtreecommitdiff
path: root/mysys/Makefile.am
diff options
context:
space:
mode:
authorserg@serg.mylan <>2004-02-27 20:30:08 +0100
committerserg@serg.mylan <>2004-02-27 20:30:08 +0100
commited2e1aa14d6b23bd1697eea54c5361be3e47cfcd (patch)
treed0f8d063fcdfa4d4c0549be6ee8d1a3d49393175 /mysys/Makefile.am
parente58f1ca7f8a5b149320d781c3dc4abb9b3a566c2 (diff)
downloadmariadb-git-ed2e1aa14d6b23bd1697eea54c5361be3e47cfcd.tar.gz
my_gethwaddr() for linux/freebsd
UUID() function
Diffstat (limited to 'mysys/Makefile.am')
-rw-r--r--mysys/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/mysys/Makefile.am b/mysys/Makefile.am
index eb6d21c360a..77b17d28ba3 100644
--- a/mysys/Makefile.am
+++ b/mysys/Makefile.am
@@ -39,7 +39,7 @@ libmysys_a_SOURCES = my_init.c my_getwd.c mf_getdate.c \
mf_format.c mf_same.c mf_dirname.c mf_fn_ext.c \
my_symlink.c my_symlink2.c \
mf_pack.c mf_unixpath.c mf_strip.c \
- mf_wcomp.c mf_wfile.c \
+ mf_wcomp.c mf_wfile.c my_gethwaddr.c \
mf_qsort.c mf_qsort2.c mf_sort.c \
ptr_cmp.c mf_radix.c queues.c \
tree.c list.c hash.c array.c string.c typelib.c \
@@ -110,5 +110,10 @@ charset2html$(EXEEXT): charset2html.c $(LIBRARIES)
testhash$(EXEEXT): testhash.c $(LIBRARIES)
$(LINK) $(FLAGS) -DMAIN $(srcdir)/testhash.c $(LDADD) $(LIBS)
+test_gethwaddr$(EXEEXT): my_gethwaddr.c $(LIBRARIES)
+ $(CP) $(srcdir)/my_gethwaddr.c ./test_gethwaddr.c
+ $(LINK) $(FLAGS) -DMAIN ./test_gethwaddr.c $(LDADD) $(LIBS)
+ $(RM) -f ./test_gethwaddr.c
+
# Don't update the files from bitkeeper
%::SCCS/s.%