summaryrefslogtreecommitdiff
path: root/mysys/Makefile.am
diff options
context:
space:
mode:
authorunknown <knielsen@mysql.com>2006-03-24 22:50:56 +0100
committerunknown <knielsen@mysql.com>2006-03-24 22:50:56 +0100
commit230eab3c68cb26fa743e82d0452f0b83359a10ff (patch)
tree4a3cb807ddfab7cd04cb6caf42623f824843f884 /mysys/Makefile.am
parenta69a37835c1b3823b359b7a4e1ae7bdafd33a08a (diff)
downloadmariadb-git-230eab3c68cb26fa743e82d0452f0b83359a10ff.tar.gz
Some changes to make it possible to build for Windows with CMake from
a normal 'make dist' source .tar.gz. libmysql/mytest.c: bk cp VC++Files/libmysqltest/mytest.c libmysql/mytest.c sql/message.mc: bk cp VC++Files/sql/message.mc sql/message.mc Makefile.am: Add Windows CMake stuff. client/Makefile.am: Add extra files needed for CMake Windows build. cmakelists.txt: Fix subdir order to make CMake dependency calculations happy. configure.in: Add extra files needed for CMake Windows build. extra/Makefile.am: Add extra files needed for CMake Windows build. extra/yassl/Makefile.am: Add extra files needed for CMake Windows build. libmysql/Makefile.am: Add extra files needed for CMake Windows build. libmysql/cmakelists.txt: Move mytest.c to a more sensible location. libmysqld/Makefile.am: Add extra files needed for CMake Windows build. mysys/Makefile.am: Add extra files needed for CMake Windows build. regex/Makefile.am: Add extra files needed for CMake Windows build. server-tools/instance-manager/Makefile.am: Add extra files needed for CMake Windows build. sql/Makefile.am: Add extra files needed for CMake Windows build. sql/cmakelists.txt: Move message.mc to a more sensible location. Add some dependencies to avoid a stale handlerton.cc. storage/archive/Makefile.am: Add extra files needed for CMake Windows build. storage/bdb/Makefile.in: Add extra files needed for CMake Windows build. storage/example/Makefile.am: Add extra files needed for CMake Windows build. storage/heap/Makefile.am: Add extra files needed for CMake Windows build. storage/innobase/Makefile.am: Add extra files needed for CMake Windows build. storage/innobase/include/univ.i: Avoid including Unix config in Windows build. storage/myisam/Makefile.am: Add extra files needed for CMake Windows build. storage/myisammrg/Makefile.am: Add extra files needed for CMake Windows build. strings/Makefile.am: Add extra files needed for CMake Windows build. tests/Makefile.am: Add extra files needed for CMake Windows build. vio/Makefile.am: Add extra files needed for CMake Windows build. zlib/Makefile.am: Add extra files needed for CMake Windows build.
Diffstat (limited to 'mysys/Makefile.am')
-rw-r--r--mysys/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/mysys/Makefile.am b/mysys/Makefile.am
index 121342bec87..51ea249bbf6 100644
--- a/mysys/Makefile.am
+++ b/mysys/Makefile.am
@@ -58,7 +58,9 @@ libmysys_a_SOURCES = my_init.c my_getwd.c mf_getdate.c my_mmap.c \
my_handler.c my_netware.c my_largepage.c \
my_windac.c my_access.c base64.c
EXTRA_DIST = thr_alarm.c thr_lock.c my_pthread.c my_thr_init.c \
- thr_mutex.c thr_rwlock.c
+ thr_mutex.c thr_rwlock.c \
+ cmakelists.txt mf_soundex.c \
+ my_conio.c my_wincond.c my_winsem.c my_winthread.c
libmysys_a_LIBADD = @THREAD_LOBJECTS@
# test_dir_DEPENDENCIES= $(LIBRARIES)
# testhash_DEPENDENCIES= $(LIBRARIES)