summaryrefslogtreecommitdiff
path: root/mysys/Makefile.am
diff options
context:
space:
mode:
authormonty@donna.mysql.com <>2000-11-18 23:13:48 +0200
committermonty@donna.mysql.com <>2000-11-18 23:13:48 +0200
commitb31d0768794e964852562c0ba307e6eea35f101b (patch)
tree287897ebd815b64a05c0ca7076beccd5245a2f8d /mysys/Makefile.am
parent23dc1a6b8568eab379492213be67d11c99522eca (diff)
downloadmariadb-git-b31d0768794e964852562c0ba307e6eea35f101b.tar.gz
Fixed some reported bugs
Diffstat (limited to 'mysys/Makefile.am')
-rw-r--r--mysys/Makefile.am23
1 files changed, 17 insertions, 6 deletions
diff --git a/mysys/Makefile.am b/mysys/Makefile.am
index d64f4959746..a53fc1a545c 100644
--- a/mysys/Makefile.am
+++ b/mysys/Makefile.am
@@ -61,7 +61,7 @@ DEFS = -DDEFAULT_BASEDIR=\"$(prefix)\" \
-DSHAREDIR="\"$(MYSQLSHAREdir)\"" \
@DEFS@
-#getopt1.o: @THREAD_LOBJECTS@
+libmysys_a_DEPENDENCIES= @THREAD_LOBJECTS@
OMIT_DEPENDENCIES = pthread.h stdio.h __stdio.h stdlib.h __stdlib.h math.h\
__math.h time.h __time.h unistd.h __unistd.h types.h \
@@ -75,11 +75,25 @@ OMIT_DEPENDENCIES = pthread.h stdio.h __stdio.h stdlib.h __stdlib.h math.h\
# I hope this always does the right thing. Otherwise this is only test programs
FLAGS=$(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS)
+#
+# The CP .. RM stuff is to avoid problems with some compilers (like alpha ccc)
+# which automaticly removes the object files you use to compile a final program
+#
+
test_thr_alarm: thr_alarm.c $(LIBRARIES)
- $(LINK) $(FLAGS) -DMAIN $(srcdir)/thr_alarm.c $(LDADD) $(LIBS)
+ $(CP) $(srcdir)/thr_alarm.c ./test_thr_alarm.c
+ $(LINK) $(FLAGS) -DMAIN ./test_thr_alarm.c $(LDADD) $(LIBS)
+ $(RM) ./test_thr_alarm.*
test_thr_lock: thr_lock.c $(LIBRARIES)
- $(LINK) $(FLAGS) -DMAIN $(srcdir)/thr_lock.c $(LDADD) $(LIBS)
+ $(CP) $(srcdir)/thr_lock.c test_thr_lock.c
+ $(LINK) $(FLAGS) -DMAIN ./test_thr_lock.c $(LDADD) $(LIBS)
+ $(RM) ./test_thr_lock.*
+
+test_vsnprintf: my_vsnprintf.c $(LIBRARIES)
+ $(CP) $(srcdir)/my_vsnprintf.c test_vsnprintf.c
+ $(LINK) $(FLAGS) -DMAIN ./test_vsnprintf.c $(LDADD) $(LIBS)
+ $(RM) test_vsnprintf.*
test_dir: test_dir.c $(LIBRARIES)
$(LINK) $(FLAGS) -DMAIN $(srcdir)/test_dir.c $(LDADD) $(LIBS)
@@ -87,9 +101,6 @@ test_dir: test_dir.c $(LIBRARIES)
test_charset: test_charset.c $(LIBRARIES)
$(LINK) $(FLAGS) -DMAIN $(srcdir)/test_charset.c $(LDADD) $(LIBS)
-test_vsnprintf: my_vsnprintf.c $(LIBRARIES)
- $(LINK) $(FLAGS) -DMAIN $(srcdir)/my_vsnprintf.c $(LDADD) $(LIBS)
-
test_hash: test_hash.c $(LIBRARIES)
$(LINK) $(FLAGS) -DMAIN $(srcdir)/test_dir.c $(LDADD) $(LIBS)