summaryrefslogtreecommitdiff
path: root/mysys/Makefile.am
diff options
context:
space:
mode:
authorMichael Widenius <monty@mysql.com>2008-10-11 11:27:03 +0300
committerMichael Widenius <monty@mysql.com>2008-10-11 11:27:03 +0300
commit56100f3a49e528315bab335edd95542590a48e61 (patch)
treedf7b9d491e2cfc2c23afa2d60af01d332a8d8d10 /mysys/Makefile.am
parentf47e003e1bfc56c2bf5d0f144a35517f526b538b (diff)
parentade71b252276f8cd3de2b325074ef1dfb5694daf (diff)
downloadmariadb-git-56100f3a49e528315bab335edd95542590a48e61.tar.gz
Merged 5.1 maria with 5.1 maria team tree. Automerge.
Diffstat (limited to 'mysys/Makefile.am')
-rw-r--r--mysys/Makefile.am11
1 files changed, 5 insertions, 6 deletions
diff --git a/mysys/Makefile.am b/mysys/Makefile.am
index 093c6d3fb27..e5e7539ece6 100644
--- a/mysys/Makefile.am
+++ b/mysys/Makefile.am
@@ -57,11 +57,12 @@ libmysys_a_SOURCES = my_init.c my_getwd.c mf_getdate.c my_mmap.c \
my_memmem.c stacktrace.c \
my_windac.c my_access.c base64.c my_libwrap.c \
wqueue.c
-EXTRA_DIST = thr_alarm.c thr_lock.c my_pthread.c my_thr_init.c \
- thr_mutex.c thr_rwlock.c waiting_threads.c \
- CMakeLists.txt mf_soundex.c \
+if THREAD
+libmysys_a_SOURCES+= thr_alarm.c thr_lock.c my_pthread.c my_thr_init.c \
+ thr_mutex.c thr_rwlock.c waiting_threads.c
+endif
+EXTRA_DIST = CMakeLists.txt mf_soundex.c \
my_conio.c my_wincond.c my_winthread.c
-libmysys_a_LIBADD = @THREAD_LOBJECTS@
# test_dir_DEPENDENCIES= $(LIBRARIES)
# testhash_DEPENDENCIES= $(LIBRARIES)
# test_charset_DEPENDENCIES= $(LIBRARIES)
@@ -75,8 +76,6 @@ DEFS = -DDEFAULT_BASEDIR=\"$(prefix)\" \
-DDEFAULT_SYSCONFDIR="\"$(sysconfdir)\"" \
@DEFS@
-libmysys_a_DEPENDENCIES= @THREAD_LOBJECTS@
-
# I hope this always does the right thing. Otherwise this is only test programs
FLAGS=$(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) @NOINST_LDFLAGS@