summaryrefslogtreecommitdiff
path: root/mysys/Makefile.am
diff options
context:
space:
mode:
authorJoerg Bruehe <joerg@mysql.com>2009-09-28 11:39:36 +0200
committerJoerg Bruehe <joerg@mysql.com>2009-09-28 11:39:36 +0200
commita6f7fbb85014a68c18d37f18d5b7809066552356 (patch)
treec0961e5b22d075d29480c7331398eb5b6f61e23e /mysys/Makefile.am
parent3baea8b9e8f26120260e2745c051a5cfee81e88b (diff)
parentd609fdf98beb8e22c8da42079e08e5dd1f84e16c (diff)
downloadmariadb-git-a6f7fbb85014a68c18d37f18d5b7809066552356.tar.gz
Merge 5.1-build up into 5.4-build ("trunk-build").
Diffstat (limited to 'mysys/Makefile.am')
-rw-r--r--mysys/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/mysys/Makefile.am b/mysys/Makefile.am
index 4b07cf89676..aedd11dc824 100644
--- a/mysys/Makefile.am
+++ b/mysys/Makefile.am
@@ -1,4 +1,4 @@
-# Copyright (C) 2000-2006 MySQL AB
+# Copyright (C) 2000-2006 MySQL AB, 2009 Sun Microsystems, Inc.
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -25,7 +25,7 @@ libmysys_a_SOURCES = my_init.c my_getwd.c mf_getdate.c my_mmap.c \
mf_path.c mf_loadpath.c my_file.c \
my_open.c my_create.c my_dup.c my_seek.c my_read.c \
my_pread.c my_write.c my_getpagesize.c \
- mf_keycache.c mf_keycaches.c my_crc32.c \
+ mf_keycaches.c my_crc32.c \
mf_iocache.c mf_iocache2.c mf_cache.c mf_tempfile.c \
mf_tempdir.c my_lock.c mf_brkhant.c my_alarm.c \
my_malloc.c my_realloc.c my_once.c mulalloc.c \
@@ -53,6 +53,14 @@ libmysys_a_SOURCES = my_init.c my_getwd.c mf_getdate.c my_mmap.c \
my_handler.c my_netware.c my_largepage.c \
my_memmem.c stacktrace.c \
my_windac.c my_access.c base64.c my_libwrap.c
+
+if NEED_THREAD
+# mf_keycache is used only in the server, so it is safe to leave the file
+# out of the non-threaded library.
+# In fact, it will currently not compile without thread support.
+libmysys_a_SOURCES += mf_keycache.c
+endif
+
EXTRA_DIST = thr_alarm.c thr_lock.c my_pthread.c my_thr_init.c \
thr_mutex.c thr_rwlock.c \
CMakeLists.txt mf_soundex.c \