summaryrefslogtreecommitdiff
path: root/ndb/Makefile.am
diff options
context:
space:
mode:
authorunknown <mronstrom@mysql.com>2004-06-01 13:19:41 +0200
committerunknown <mronstrom@mysql.com>2004-06-01 13:19:41 +0200
commitc32a2521f025eebdbbc272b54aa64668f4dcc8e2 (patch)
treef39e494ef9a57ba19dc0dce2c8e55b2c1bc3013c /ndb/Makefile.am
parentc4cb7a9b430fbde0ac977f7cce81270b5b778f12 (diff)
parent0bfc8c57ca2f3c5e8f56e12604eb94e1dc47ec9f (diff)
downloadmariadb-git-c32a2521f025eebdbbc272b54aa64668f4dcc8e2.tar.gz
Merge mronstrom@bk-internal.mysql.com:/home/bk/mysql-4.1-ndb
into mysql.com:/Users/mikron/mycluster
Diffstat (limited to 'ndb/Makefile.am')
-rw-r--r--ndb/Makefile.am20
1 files changed, 15 insertions, 5 deletions
diff --git a/ndb/Makefile.am b/ndb/Makefile.am
index c83c9f1fa48..27274ec1eb2 100644
--- a/ndb/Makefile.am
+++ b/ndb/Makefile.am
@@ -1,7 +1,4 @@
-## find * -name '*.hpp' -print | grep -v SCCS | grep -v odbc | sed 's/\.hpp/\.hpp \\/' > tmp.out
-## find * -name '*.h' -print | grep -v SCCS | grep -v odbc | sed 's/\.h/\.h \\/' >> tmp.out
-
-SUBDIRS = . include src test tools
+SUBDIRS = src test tools .
ndbinclude_HEADERS = \
include/ndb_types.h \
@@ -31,4 +28,17 @@ mgmapiinclude_HEADERS = \
include/mgmapi/mgmapi.h \
include/mgmapi/mgmapi_debug.h
-noinst_HEADERS =
+EXTRA_DIST = include
+
+dist-hook:
+ -rm -rf `find $(distdir) -type d -name SCCS`
+ list='$(SUBDIRS)'; for subdir in $$list; do \
+ if test "$$subdir" != "."; then \
+ files="`find $$subdir -name '*\.h'` `find $$subdir -name '*\.hpp'`"; \
+ for f in $$files; do \
+ if test -d "$(distdir)/`dirname $$f`" -a ! -e "$(distdir)/$$f"; then \
+ cp $$f $(distdir)/$$f; \
+ fi; \
+ done; \
+ fi; \
+ done