summaryrefslogtreecommitdiff
path: root/ndb/docs/Makefile.am
diff options
context:
space:
mode:
authorunknown <tomas@mc05.(none)>2004-06-15 08:14:20 +0200
committerunknown <tomas@mc05.(none)>2004-06-15 08:14:20 +0200
commit42d9baf933c893c45269234ca0b3d705dc256e65 (patch)
treec99f0af498d96ea06c28b025171c02c9f05c8d71 /ndb/docs/Makefile.am
parent61540a24d75d8657f214848fac8f09c7cf2a9169 (diff)
downloadmariadb-git-42d9baf933c893c45269234ca0b3d705dc256e65.tar.gz
ndb fixes for make dist
mysql-test/ndb/ndbcluster.sh: Change mode to -rw-rw-r--
Diffstat (limited to 'ndb/docs/Makefile.am')
-rw-r--r--ndb/docs/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/ndb/docs/Makefile.am b/ndb/docs/Makefile.am
index fb367fb9345..554b2fb256e 100644
--- a/ndb/docs/Makefile.am
+++ b/ndb/docs/Makefile.am
@@ -1,7 +1,8 @@
+DOXYDIR = doxygen
+noinst_HEADERS = $(DOXYDIR)/predoxy.pl $(DOXYDIR)/postdoxy.pl $(DOXYDIR)/Doxyfile.ndbapi $(DOXYDIR)/Doxyfile.mgmapi $(DOXYDIR)/header.ndbapi.tex $(DOXYDIR)/header.mgmapi.tex
all: do-check ndbapidoc mgmapidoc
-DOXYDIR = doxygen
DOXYTMP = .doxytmp
DOXYOUT = .doxyout
@@ -35,7 +36,7 @@ do-check:
#
ndbapidoc: ndbapi.pdf
-ndbapi.pdf: $(top_srcdir)/ndb/include/ndb_version.h
+ndbapi.pdf: $(noinst_HEADERS)
@set -x; \
export NDB_RELEASE=$(NDB_RELEASE) \
@RM@ -f ndbapi.pdf ndbapi.html; \
@@ -59,7 +60,7 @@ ndbapi.pdf: $(top_srcdir)/ndb/include/ndb_version.h
#
mgmapidoc: mgmapi.pdf
-mgmapi.pdf: $(top_srcdir)/ndb/include/ndb_version.h
+mgmapi.pdf: $(noinst_HEADERS)
@set -x; \
export NDB_RELEASE=$(NDB_RELEASE) \
@RM@ -f mgmapi.pdf mgmapi.html; \