summaryrefslogtreecommitdiff
path: root/ndb/src/Makefile.am
diff options
context:
space:
mode:
authorunknown <tomas@poseidon.ndb.mysql.com>2004-11-14 11:02:06 +0000
committerunknown <tomas@poseidon.ndb.mysql.com>2004-11-14 11:02:06 +0000
commitbbe9e857e6aff7116bd816d2c2e3f39905abee43 (patch)
tree57617e59cb2ee43ba481c87b953a8a7f43ac17d8 /ndb/src/Makefile.am
parentae39bbf7ccf1a4f21911d14996e60a16814d8af8 (diff)
downloadmariadb-git-bbe9e857e6aff7116bd816d2c2e3f39905abee43.tar.gz
moved ndb_restore together with rest of the ndb tools
kernel includes needed by ndb_restore changed link order moved LocalConfig to mgmapi Moved NdbConfig to Portlib mgmapi to use LocalConfig for connectstring parsing instead of it's own enable usage of "NULL" connectstring for default new ndbmgmclient lib that can be used by e.g. mysqladmin later LocalConfig no longer needed here, now in mgmapi Send connectstring to mgmapi instead added valid connectstring to be with only host without port i.e. valid connectstring =host1,host2,host3 default port will be added ndb/src/common/portlib/NdbConfig.c: Rename: ndb/src/common/mgmcommon/NdbConfig.c -> ndb/src/common/portlib/NdbConfig.c ndb/include/portlib/NdbConfig.h: Rename: ndb/include/mgmcommon/NdbConfig.h -> ndb/include/portlib/NdbConfig.h ndb/include/mgmapi/LocalConfig.hpp: Rename: ndb/include/mgmcommon/LocalConfig.hpp -> ndb/include/mgmapi/LocalConfig.hpp ndb/tools/restore/Makefile.am: Rename: ndb/src/kernel/blocks/backup/restore/Makefile.am -> ndb/tools/restore/Makefile.am ndb/tools/restore/consumer.cpp: Rename: ndb/src/kernel/blocks/backup/restore/consumer.cpp -> ndb/tools/restore/consumer.cpp ndb/tools/restore/consumer.hpp: Rename: ndb/src/kernel/blocks/backup/restore/consumer.hpp -> ndb/tools/restore/consumer.hpp ndb/tools/restore/consumer_printer.hpp: Rename: ndb/src/kernel/blocks/backup/restore/consumer_printer.hpp -> ndb/tools/restore/consumer_printer.hpp ndb/tools/restore/consumer_printer.cpp: Rename: ndb/src/kernel/blocks/backup/restore/consumer_printer.cpp -> ndb/tools/restore/consumer_printer.cpp ndb/tools/restore/consumer_restore.hpp: Rename: ndb/src/kernel/blocks/backup/restore/consumer_restore.hpp -> ndb/tools/restore/consumer_restore.hpp ndb/tools/restore/main.cpp: Rename: ndb/src/kernel/blocks/backup/restore/main.cpp -> ndb/tools/restore/main.cpp ndb/tools/restore/consumer_restorem.cpp: Rename: ndb/src/kernel/blocks/backup/restore/consumer_restorem.cpp -> ndb/tools/restore/consumer_restorem.cpp configure.in: moved ndb_restore together with rest of the ndb tools ndb/config/type_ndbapitools.mk.am: kernel includes needed by ndb_restore ndb/src/Makefile.am: changed link order ndb/src/common/mgmcommon/Makefile.am: mived LocalConfig to mgmapi ndb/src/common/portlib/Makefile.am: Moved NdbConfig to Portlib ndb/src/kernel/blocks/backup/Makefile.am: moved restore together with rest of ndb tools ndb/src/mgmapi/LocalConfig.cpp: added valid connectstring to be with only host without port i.e. valid connectstring =host1,host2,host3 default port will be added ndb/src/mgmapi/Makefile.am: LocalConfig part of the libmgmapi ndb/src/mgmapi/mgmapi.cpp: mgmapi to use LocalConfig for connectstring parsing instead of it's own ndb/src/mgmclient/CommandInterpreter.cpp: enable usage of "NULL" connectstring for default ndb/src/mgmclient/Makefile.am: new ndbmgmclient lib that can be used by e.g. mysqladmin later ndb/src/mgmclient/main.cpp: LocalConfig no longer needed here, now in mgmapi Send connectstring to mgmapi instead ndb/tools/Makefile.am: add ndb_restore to make of tools ndb/tools/restore/Restore.cpp: moved include BackupFormat and NdbDictionaryImpl to Restore.hpp ndb/tools/restore/Restore.hpp: moved include BackupFormat and NdbDictionaryImpl to Restore.hpp ndb/tools/restore/consumer_restore.cpp: moved include BackupFormat and NdbDictionaryImpl to Restore.hpp ndb/tools/waiter.cpp: LocalConfig moved
Diffstat (limited to 'ndb/src/Makefile.am')
-rw-r--r--ndb/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/ndb/src/Makefile.am b/ndb/src/Makefile.am
index bed43438e91..36a4c3f247f 100644
--- a/ndb/src/Makefile.am
+++ b/ndb/src/Makefile.am
@@ -11,8 +11,8 @@ libndbclient_la_LIBADD = \
common/transporter/libtransporter.la \
common/debugger/libtrace.la \
common/debugger/signaldata/libsignaldataprint.la \
- common/mgmcommon/libmgmsrvcommon.la \
mgmapi/libmgmapi.la \
+ common/mgmcommon/libmgmsrvcommon.la \
common/logger/liblogger.la \
common/portlib/libportlib.la \
common/util/libgeneral.la