summaryrefslogtreecommitdiff
path: root/ndb/src/mgmsrv/Makefile.am
diff options
context:
space:
mode:
authorunknown <tomas@poseidon.(none)>2004-08-27 11:48:27 +0000
committerunknown <tomas@poseidon.(none)>2004-08-27 11:48:27 +0000
commit987fc113959189c59e8f6e99d8d5364d9d62bc89 (patch)
tree553669a934f12f62a64ba7fd2729840a40015ef3 /ndb/src/mgmsrv/Makefile.am
parent6566af8c3599d6ca6f3110a02d4e8476d386888e (diff)
downloadmariadb-git-987fc113959189c59e8f6e99d8d5364d9d62bc89.tar.gz
see respective file
ndb/src/mgmsrv/InitConfigFileParser.hpp: Rename: ndb/src/common/mgmcommon/InitConfigFileParser.hpp -> ndb/src/mgmsrv/InitConfigFileParser.hpp ndb/src/mgmsrv/InitConfigFileParser.cpp: Rename: ndb/src/common/mgmcommon/InitConfigFileParser.cpp -> ndb/src/mgmsrv/InitConfigFileParser.cpp ndb/src/mgmsrv/ConfigInfo.hpp: Rename: ndb/src/common/mgmcommon/ConfigInfo.hpp -> ndb/src/mgmsrv/ConfigInfo.hpp ndb/src/common/mgmcommon/Makefile.am: moved files to mgmsrv ndb/src/mgmclient/CommandInterpreter.cpp: added shutdown command ndb/src/mgmclient/CommandInterpreter.hpp: added shutdown command ndb/src/mgmsrv/Config.cpp: . ndb/src/mgmsrv/Config.hpp: . ndb/src/mgmsrv/ConfigInfo.cpp: wait with this ndb/src/mgmsrv/Makefile.am: moved files to mgmsrv ndb/test/include/NdbBackup.hpp: backup not necessarily in file system path ndb/test/ndbapi/testDict.cpp: compile error ndb/test/src/NdbBackup.cpp: aligned with new config param
Diffstat (limited to 'ndb/src/mgmsrv/Makefile.am')
-rw-r--r--ndb/src/mgmsrv/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/ndb/src/mgmsrv/Makefile.am b/ndb/src/mgmsrv/Makefile.am
index 630a19e0356..60b579d18e1 100644
--- a/ndb/src/mgmsrv/Makefile.am
+++ b/ndb/src/mgmsrv/Makefile.am
@@ -1,3 +1,7 @@
+MYSQLDATAdir = $(localstatedir)
+MYSQLSHAREdir = $(pkgdatadir)
+MYSQLBASEdir= $(prefix)
+MYSQLCLUSTERdir= $(prefix)/mysql-cluster
ndbbin_PROGRAMS = ndb_mgmd
@@ -11,6 +15,9 @@ ndb_mgmd_SOURCES = \
NodeLogLevelList.cpp \
SignalQueue.cpp \
MgmtSrvrConfig.cpp \
+ ConfigInfo.cpp \
+ InitConfigFileParser.cpp \
+ Config.cpp \
CommandInterpreter.cpp
INCLUDES_LOC = -I$(top_srcdir)/ndb/src/ndbapi \
@@ -24,6 +31,12 @@ LDADD_LOC = $(top_builddir)/ndb/src/libndbclient.la \
$(top_builddir)/strings/libmystrings.a
@TERMCAP_LIB@
+DEFS_LOC = -DDEFAULT_MYSQL_HOME="\"$(MYSQLBASEdir)\"" \
+ -DDATADIR="\"$(MYSQLDATAdir)\"" \
+ -DSHAREDIR="\"$(MYSQLSHAREdir)\"" \
+ -DMYSQLCLUSTERDIR="\"$(MYSQLCLUSTERdir)\"" \
+ -DNDB_BASE_PORT="\"@ndb_port_base@\""
+
include $(top_srcdir)/ndb/config/common.mk.am
include $(top_srcdir)/ndb/config/type_ndbapi.mk.am