summaryrefslogtreecommitdiff
path: root/ndb/src/mgmsrv/Makefile.am
diff options
context:
space:
mode:
authorunknown <tomas@poseidon.ndb.mysql.com>2004-11-10 16:05:28 +0000
committerunknown <tomas@poseidon.ndb.mysql.com>2004-11-10 16:05:28 +0000
commitb6ed85ba5a884145723058344571b682de3f4c9e (patch)
tree364c6c40f694a800ae1d5172a69490ab4871f9c9 /ndb/src/mgmsrv/Makefile.am
parenta12d6fd6a7277f71ee8857c7b8f00c4e574bc752 (diff)
downloadmariadb-git-b6ed85ba5a884145723058344571b682de3f4c9e.tar.gz
added configure switch for ndb port number
added new variable for ndb port 1186 changed meaning of ndb_port_base to be default tcp port setting changed to use split between port and port_base for ndbcluster so that ndb_port and ndb_port_base are propagated to startscript for ndbcluster added larger space to pid print moved readAndExecute out of CommandInterpreter to avoid linking lib with readline added c-api to Ndb_mgmclient pass also ndb_port to make acinclude.m4: added configure switch for ndb port number configure.in: added new variable for ndb port 1186 changed meaning of ndb_port_base to be default tcp port setting mysql-test/mysql-test-run.sh: changed to use split between port and port_base for ndbcluster mysql-test/ndb/Makefile.am: so that ndb_port and ndb_port_base are propagated to startscript for ndbcluster mysql-test/ndb/ndbcluster.sh: so that ndb_port and ndb_port_base are propagated to startscript for ndbcluster ndb/src/common/mgmcommon/LocalConfig.cpp: so that ndb_port and ndb_port_base are propagated to startscript for ndbcluster ndb/src/common/mgmcommon/Makefile.am: so that ndb_port and ndb_port_base are propagated to startscript for ndbcluster ndb/src/common/mgmcommon/NdbConfig.c: added larger space to pid print ndb/src/mgmclient/CommandInterpreter.cpp: moved readAndExecute out of CommandInterpreter to avoid linking lib with readline added c-api to Ndb_mgmclient ndb/src/mgmclient/main.cpp: moved readAndExecute out of CommandInterpreter to avoid linking lib with readline ndb/src/mgmclient/ndb_mgmclient.hpp: moved readAndExecute out of CommandInterpreter to avoid linking lib with readline ndb/src/mgmsrv/ConfigInfo.cpp: moved readAndExecute out of CommandInterpreter to avoid linking lib with readline ndb/src/mgmsrv/Makefile.am: pass also ndb_port to make
Diffstat (limited to 'ndb/src/mgmsrv/Makefile.am')
-rw-r--r--ndb/src/mgmsrv/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/ndb/src/mgmsrv/Makefile.am b/ndb/src/mgmsrv/Makefile.am
index 4cb164d48fe..ee5220ef9f8 100644
--- a/ndb/src/mgmsrv/Makefile.am
+++ b/ndb/src/mgmsrv/Makefile.am
@@ -33,6 +33,7 @@ DEFS_LOC = -DDEFAULT_MYSQL_HOME="\"$(MYSQLBASEdir)\"" \
-DDATADIR="\"$(MYSQLDATAdir)\"" \
-DSHAREDIR="\"$(MYSQLSHAREdir)\"" \
-DMYSQLCLUSTERDIR="\"$(MYSQLCLUSTERdir)\"" \
+ -DNDB_PORT="\"@ndb_port@\"" \
-DNDB_BASE_PORT="\"@ndb_port_base@\""
include $(top_srcdir)/ndb/config/common.mk.am