summaryrefslogtreecommitdiff
path: root/ndb/test/ndbapi/Makefile.am
diff options
context:
space:
mode:
authorunknown <pekka@mysql.com>2006-05-15 19:53:29 +0200
committerunknown <pekka@mysql.com>2006-05-15 19:53:29 +0200
commitce7a7b20d1afa0fb1ba0e85430114193ba45cbdd (patch)
tree367eece2bd8242e666c569ce66e77a8ebba1ba32 /ndb/test/ndbapi/Makefile.am
parent774fae9c6b8b885c2644afffd6f5914c1a829826 (diff)
downloadmariadb-git-ce7a7b20d1afa0fb1ba0e85430114193ba45cbdd.tar.gz
ndb - bug#19537: arithmetic conversion Uint64 reg to Uint32 attr
ndb/test/ndbapi/Makefile.am: enable testInterpreter ndb/test/ndbapi/testInterpreter.cpp: add test case Bug19537 the bug fix also fixed IncValue64 for whatever reason.. ndb/src/kernel/blocks/dbtup/DbtupExecQuery.cpp: bug#19537: write_attr: perform arithmetic conversion Uint64 to Uint32
Diffstat (limited to 'ndb/test/ndbapi/Makefile.am')
-rw-r--r--ndb/test/ndbapi/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/ndb/test/ndbapi/Makefile.am b/ndb/test/ndbapi/Makefile.am
index 7b4a96f5890..29bbbb74422 100644
--- a/ndb/test/ndbapi/Makefile.am
+++ b/ndb/test/ndbapi/Makefile.am
@@ -24,6 +24,7 @@ testOIBasic \
testOperations \
testRestartGci \
testScan \
+testInterpreter \
testScanInterpreter \
testScanPerf \
testSystemRestart \
@@ -61,6 +62,7 @@ testOIBasic_SOURCES = testOIBasic.cpp
testOperations_SOURCES = testOperations.cpp
testRestartGci_SOURCES = testRestartGci.cpp
testScan_SOURCES = testScan.cpp ScanFunctions.hpp
+testInterpreter_SOURCES = testInterpreter.cpp
testScanInterpreter_SOURCES = testScanInterpreter.cpp ScanFilter.hpp ScanInterpretTest.hpp
testScanPerf_SOURCES = testScanPerf.cpp
testSystemRestart_SOURCES = testSystemRestart.cpp
@@ -152,3 +154,4 @@ testScan.dsp: Makefile \
@$(top_srcdir)/ndb/config/win-includes $@ $(INCLUDES)
@$(top_srcdir)/ndb/config/win-sources $@ $(testScan_SOURCES)
@$(top_srcdir)/ndb/config/win-libraries $@ LINK $(LDADD)
+