summaryrefslogtreecommitdiff
path: root/ndb/tools/Makefile.am
diff options
context:
space:
mode:
authorunknown <joreland@mysql.com>2004-11-16 07:22:30 +0100
committerunknown <joreland@mysql.com>2004-11-16 07:22:30 +0100
commiteb05d78dcb8074a5dfceedf8c86681531fc3bfbe (patch)
tree39dc847742b930a3c542d1b3020b1463a0392371 /ndb/tools/Makefile.am
parent1f947d4ba8fb3870d9f5b2334a69c9ea5116ba69 (diff)
parent546e2d3192ed0b5745bf22cbc61f9aec44b426a8 (diff)
downloadmariadb-git-eb05d78dcb8074a5dfceedf8c86681531fc3bfbe.tar.gz
merge
configure.in: Auto merged ndb/src/Makefile.am: Auto merged ndb/src/common/mgmcommon/Makefile.am: Auto merged ndb/src/common/portlib/Makefile.am: Auto merged ndb/src/common/portlib/NdbConfig.c: Auto merged ndb/src/common/transporter/TransporterRegistry.cpp: Auto merged ndb/src/kernel/blocks/backup/Makefile.am: Auto merged ndb/src/mgmapi/Makefile.am: Auto merged ndb/src/mgmclient/Makefile.am: Auto merged ndb/tools/Makefile.am: Auto merged
Diffstat (limited to 'ndb/tools/Makefile.am')
-rw-r--r--ndb/tools/Makefile.am17
1 files changed, 14 insertions, 3 deletions
diff --git a/ndb/tools/Makefile.am b/ndb/tools/Makefile.am
index cf78eeadac7..8d78a3dcad9 100644
--- a/ndb/tools/Makefile.am
+++ b/ndb/tools/Makefile.am
@@ -8,9 +8,12 @@ ndbtools_PROGRAMS = \
ndb_drop_index \
ndb_show_tables \
ndb_select_all \
- ndb_select_count
+ ndb_select_count \
+ ndb_restore
-tools_common_sources = ../test/src/NDBT_ReturnCodes.cpp ../test/src/NDBT_Table.cpp ../test/src/NDBT_Output.cpp
+tools_common_sources = ../test/src/NDBT_ReturnCodes.cpp \
+ ../test/src/NDBT_Table.cpp \
+ ../test/src/NDBT_Output.cpp
ndb_test_platform_SOURCES = ndb_test_platform.cpp
ndb_waiter_SOURCES = waiter.cpp $(tools_common_sources)
@@ -19,8 +22,15 @@ ndb_desc_SOURCES = desc.cpp $(tools_common_sources)
ndb_drop_index_SOURCES = drop_index.cpp $(tools_common_sources)
ndb_drop_table_SOURCES = drop_tab.cpp $(tools_common_sources)
ndb_show_tables_SOURCES = listTables.cpp $(tools_common_sources)
-ndb_select_all_SOURCES = select_all.cpp ../test/src/NDBT_ResultRow.cpp $(tools_common_sources)
+ndb_select_all_SOURCES = select_all.cpp \
+ ../test/src/NDBT_ResultRow.cpp \
+ $(tools_common_sources)
ndb_select_count_SOURCES = select_count.cpp $(tools_common_sources)
+ndb_restore_SOURCES = restore/main.cpp \
+ restore/consumer.cpp \
+ restore/consumer_restore.cpp \
+ restore/consumer_printer.cpp \
+ restore/Restore.cpp
include $(top_srcdir)/ndb/config/common.mk.am
include $(top_srcdir)/ndb/config/type_ndbapitools.mk.am
@@ -34,6 +44,7 @@ ndb_drop_index_LDFLAGS = @ndb_bin_am_ldflags@
ndb_show_tables_LDFLAGS = @ndb_bin_am_ldflags@
ndb_select_all_LDFLAGS = @ndb_bin_am_ldflags@
ndb_select_count_LDFLAGS = @ndb_bin_am_ldflags@
+ndb_restore_LDFLAGS = @ndb_bin_am_ldflags@
# Don't update the files from bitkeeper
%::SCCS/s.%