summaryrefslogtreecommitdiff
path: root/netware/Makefile.am
diff options
context:
space:
mode:
authorunknown <joerg@trift2.>2007-08-24 23:07:59 +0200
committerunknown <joerg@trift2.>2007-08-24 23:07:59 +0200
commit4a801dde7ea531f16a261e860eb6bb30b497166d (patch)
treedad6764618b2ecdf7a17ad7942061e3d4f8a5ca1 /netware/Makefile.am
parent46d5ebb120f17e9e2ad1490d1e572a3b0cd145bf (diff)
downloadmariadb-git-4a801dde7ea531f16a261e860eb6bb30b497166d.tar.gz
Fixes for the NetWare builds, discovered during 5.1.21-beta and backported to 5.0:
1) Ensure "init_db.sql" and "test_db-sql" really get built. 2) Ensure the "*.def" files with NetWare linker options get distributed to the proper directories. netware/BUILD/compile-netware-END: Ensure the "*.def" files are built for NetWare. This is a backport of a 5.1 fix which may not be needed in 5.0 but cannot do any harm: the general "link_sources" step might fall victim to a cleanup which would be fatal just for NetWare, because of problems in the ordering of SUBDIR entries. netware/Makefile.am: 1) The scripts "init_db.sql" and "test_db.sql" must be built in the NetWare phase. 2) Use "basename", not sed.
Diffstat (limited to 'netware/Makefile.am')
-rw-r--r--netware/Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/netware/Makefile.am b/netware/Makefile.am
index 3ec9c7794bf..296b5a391c4 100644
--- a/netware/Makefile.am
+++ b/netware/Makefile.am
@@ -40,13 +40,19 @@ netware_build_files = client/mysql.def client/mysqladmin.def \
sql/mysqld.def extra/mysql_waitpid.def \
extra/resolve_stack_dump.def myisam/myisam_ftdump.def
+BUILT_SOURCES = link_sources init_db.sql test_db.sql
+CLEANFILES = $(BUILT_SOURCES)
+
+all: $(BUILT_SOURCES)
+
link_sources:
set -x; \
for f in $(netware_build_files); do \
rm -f ../$$f; \
- org=`echo $$f | sed -e 's/.*\/\(.*\)/\1/g'`; \
+ org=`basename $$f`; \
@LN_CP_F@ $(srcdir)/$$org ../$$f; \
done
+
else
BUILT_SOURCES = libmysql.imp init_db.sql test_db.sql
@@ -86,6 +92,8 @@ EXTRA_DIST= $(BUILT_SOURCES) comp_err.def install_test_db.ncf \
BUILD/mwasmnlm BUILD/mwccnlm BUILD/mwenv BUILD/mwldnlm \
BUILD/nwbootstrap BUILD/openssl.imp BUILD/save-patch
+endif
+
# Build init_db.sql from the files that contain
# the system tables for this version of MySQL plus any commands
@@ -103,9 +111,7 @@ init_db.sql: $(top_srcdir)/scripts/mysql_system_tables.sql \
test_db.sql: init_db.sql $(top_srcdir)/scripts/mysql_test_data_timezone.sql
@echo "Building $@";
@cat init_db.sql \
- $(top_srcdir)/scripts/mysql_test_data_timezone.sql >> $@;
-
-endif
+ $(top_srcdir)/scripts/mysql_test_data_timezone.sql > $@;
# Don't update the files from bitkeeper
%::SCCS/s.%