summaryrefslogtreecommitdiff
path: root/netware/Makefile.am
diff options
context:
space:
mode:
authorunknown <joerg@trift2.>2007-08-24 23:12:19 +0200
committerunknown <joerg@trift2.>2007-08-24 23:12:19 +0200
commit454063c5a96ec9904485501cd3a7dd8750937249 (patch)
treecc97327132353f748f2ac358730e9a8d4ab3aa9f /netware/Makefile.am
parent813c25108afa34f1cae77619512913f32d5c8fb1 (diff)
parent4a801dde7ea531f16a261e860eb6bb30b497166d (diff)
downloadmariadb-git-454063c5a96ec9904485501cd3a7dd8750937249.tar.gz
Merge trift2.:/MySQL/M50/netware2-5.0
into trift2.:/MySQL/M51/netware2-5.1 netware/BUILD/compile-netware-END: Auto merged netware/Makefile.am: Manual merge.
Diffstat (limited to 'netware/Makefile.am')
-rw-r--r--netware/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/netware/Makefile.am b/netware/Makefile.am
index df0072b3a2b..5d66e6052e3 100644
--- a/netware/Makefile.am
+++ b/netware/Makefile.am
@@ -43,10 +43,15 @@ netware_build_files = client/mysql.def client/mysqladmin.def \
storage/myisam/myisampack.def \
storage/myisam/myisam_ftdump.def
+BUILT_SOURCES = link_sources init_db.sql test_db.sql
+CLEANFILES = $(BUILT_SOURCES)
+
+all: $(BUILT_SOURCES)
+
link_sources:
for f in $(netware_build_files); do \
rm -f ../$$f; \
- org=`echo $$f | sed -e 's/.*\/\(.*\)/\1/g'`; \
+ org=`basename $$f`; \
@LN_CP_F@ $(srcdir)/$$org ../$$f; \
done
echo timestamp > link_sources
@@ -94,6 +99,8 @@ EXTRA_DIST= $(BUILT_SOURCES) comp_err.def install_test_db.ncf \
BUILD/mwasmnlm BUILD/mwccnlm BUILD/mwenv BUILD/mwldnlm \
BUILD/nwbootstrap BUILD/openssl.imp BUILD/save-patch
+endif
+
# Build init_db.sql from the files that contain
# the system tables for this version of MySQL plus any commands
@@ -111,9 +118,7 @@ init_db.sql: $(top_srcdir)/scripts/mysql_system_tables.sql \
test_db.sql: init_db.sql $(top_srcdir)/scripts/mysql_test_data_timezone.sql
@echo "Building $@";
@cat init_db.sql \
- $(top_srcdir)/scripts/mysql_test_data_timezone.sql >> $@;
-
-endif
+ $(top_srcdir)/scripts/mysql_test_data_timezone.sql > $@;
# Don't update the files from bitkeeper
%::SCCS/s.%