summaryrefslogtreecommitdiff
path: root/netware/Makefile.am
diff options
context:
space:
mode:
authorunknown <joerg@trift2.>2007-03-16 20:56:16 +0100
committerunknown <joerg@trift2.>2007-03-16 20:56:16 +0100
commit77fccd038f7b6e177c7dd6d5ff28d0490589598f (patch)
tree36ced2a6fff684bfdf114994909aec672e4a92b6 /netware/Makefile.am
parent92384c67442d0e45065093ce2d48d4d5161c3e51 (diff)
downloadmariadb-git-77fccd038f7b6e177c7dd6d5ff28d0490589598f.tar.gz
Bug#20166 mysql-test-run.pl does not test system privilege tables creation
- Build sql files for netware from the mysql_system_tables*.sq files - Fix comments about mysql_create_system_tables.sh - Use mysql_install_db.sh to create system tables for mysql_test-run-shell - Fix mysql-test-run.pl to also look in share/mysql for the msyql_system*.sql files Changeset coded today by Magnus Svensson, just the application to 5.0.38 is by Joerg Bruehe. BitKeeper/deleted/.del-init_db.sql~e2b8d0c8390e8023: Delete: netware/init_db.sql BitKeeper/deleted/.del-test_db.sql: Delete: netware/test_db.sql BitKeeper/etc/ignore: Added netware/init_db.sql netware/test_db.sql to the ignore list mysql-test/install_test_db.sh: Use mysql_install_db from install_test_db(which is used by mysql-test-run-shell) to install the system tables mysql-test/mysql-test-run.pl: Look for the mysql_system_tables*.sql also in share/mysql netware/Makefile.am: Build netware/init_db.sql and netware/test_db.sql from the sources in scripts/msyql_system_tables*.sql scripts/make_binary_distribution.sh: netware/init_db.sql and netware/test_db.sql are now built by the Makefiles from the scripts/mysql_system_tables*.sql files sql/mysql_priv.h: Update comment remindging to update the MySQL system table definitions when adding a new SQL_MODE sql/sql_acl.h: Update comment reminding to update the MySQL System tables when changing the ACL defines
Diffstat (limited to 'netware/Makefile.am')
-rw-r--r--netware/Makefile.am28
1 files changed, 24 insertions, 4 deletions
diff --git a/netware/Makefile.am b/netware/Makefile.am
index de39376f6a1..8a9945fc6a4 100644
--- a/netware/Makefile.am
+++ b/netware/Makefile.am
@@ -49,8 +49,8 @@ link_sources:
done
else
-BUILT_SOURCES = libmysql.imp
-DISTCLEANFILES = $(BUILT_SOURCES)
+BUILT_SOURCES = libmysql.imp init_db.sql test_db.sql
+CLEANFILES = $(BUILT_SOURCES)
# Create the libmysql.imp from libmysql/libmysql.def
libmysql.imp: $(top_srcdir)/libmysql/libmysql.def
@@ -60,7 +60,7 @@ libmysql.imp: $(top_srcdir)/libmysql/libmysql.def
x>1 {printf(",\n %s", $$1); next} \
/EXPORTS/{x=1}' $(top_srcdir)/libmysql/libmysql.def > libmysql.imp
-EXTRA_DIST= $(BUILT_SOURCES) comp_err.def init_db.sql install_test_db.ncf \
+EXTRA_DIST= $(BUILT_SOURCES) comp_err.def install_test_db.ncf \
libmysql.def \
libmysqlmain.c my_manage.c my_manage.h \
my_print_defaults.def myisam_ftdump.def myisamchk.def \
@@ -73,7 +73,7 @@ EXTRA_DIST= $(BUILT_SOURCES) comp_err.def init_db.sql install_test_db.ncf \
mysqld_safe.c mysqld_safe.def mysqldump.def mysqlimport.def \
mysqlshow.def mysqltest.def mysql_upgrade.def perror.def \
mysql_client_test.def \
- replace.def resolve_stack_dump.def resolveip.def test_db.sql \
+ replace.def resolve_stack_dump.def resolveip.def \
static_init_db.sql \
BUILD/apply-patch BUILD/compile-AUTOTOOLS \
BUILD/compile-linux-tools BUILD/compile-netware-END \
@@ -84,6 +84,26 @@ EXTRA_DIST= $(BUILT_SOURCES) comp_err.def init_db.sql install_test_db.ncf \
BUILD/cron-build BUILD/crontab BUILD/knetware.imp \
BUILD/mwasmnlm BUILD/mwccnlm BUILD/mwenv BUILD/mwldnlm \
BUILD/nwbootstrap BUILD/openssl.imp BUILD/save-patch
+
+
+# Build init_db.sql from the files that contain
+# the system tables for this version of MySQL plus any commands
+init_db.sql: $(top_srcdir)/scripts/mysql_system_tables.sql \
+ $(top_srcdir)/scripts/mysql_system_tables_data.sql
+ @echo "Building $@";
+ @echo "CREATE DATABASE mysql;" > $@;
+ @echo "CREATE DATABASE test;" >> $@;
+ @echo "use mysql;" >> $@;
+ @cat $(top_srcdir)/scripts/mysql_system_tables.sql \
+ $(top_srcdir)/scripts/mysql_system_tables_fix.sql >> $@;
+
+# Build test_db.sql from init_db.sql plus
+# some test data
+test_db.sql: init_db.sql $(top_srcdir)/scripts/mysql_test_data_timezone.sql
+ @echo "Building $@";
+ @cat init_db.sql \
+ $(top_srcdir)/scripts/mysql_test_data_timezone.sql >> $@;
+
endif
# Don't update the files from bitkeeper