summaryrefslogtreecommitdiff
path: root/netware/Makefile.am
diff options
context:
space:
mode:
authorunknown <joerg@trift2.>2007-08-24 23:40:36 +0200
committerunknown <joerg@trift2.>2007-08-24 23:40:36 +0200
commitac7f0f98d654b19c7d8a9ddf203b650e52f8856b (patch)
tree187c41fd261958a0a1c8792ea4458e1da11e2c8f /netware/Makefile.am
parent7d65f9e891dc3d28ee02d975c384c9d7a41162b3 (diff)
parent4a801dde7ea531f16a261e860eb6bb30b497166d (diff)
downloadmariadb-git-ac7f0f98d654b19c7d8a9ddf203b650e52f8856b.tar.gz
Merge trift2.:/MySQL/M50/netware2-5.0
into trift2.:/MySQL/M50/push-5.0 netware/Makefile.am: Auto merged
Diffstat (limited to 'netware/Makefile.am')
-rw-r--r--netware/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/netware/Makefile.am b/netware/Makefile.am
index 1e006bbc25b..2e9ff2b59d6 100644
--- a/netware/Makefile.am
+++ b/netware/Makefile.am
@@ -40,6 +40,11 @@ netware_build_files = client/mysql.def client/mysqladmin.def \
sql/mysqld.def extra/mysql_waitpid.def \
extra/resolve_stack_dump.def myisam/myisam_ftdump.def
+BUILT_SOURCES = link_sources init_db.sql test_db.sql
+CLEANFILES = $(BUILT_SOURCES)
+
+all: $(BUILT_SOURCES)
+
link_sources:
set -x; \
for f in $(netware_build_files); do \
@@ -47,6 +52,7 @@ link_sources:
org=`basename $$f`; \
@LN_CP_F@ $(srcdir)/$$org ../$$f; \
done
+
else
BUILT_SOURCES = libmysql.imp init_db.sql test_db.sql
@@ -86,6 +92,8 @@ EXTRA_DIST= $(BUILT_SOURCES) comp_err.def install_test_db.ncf \
BUILD/mwasmnlm BUILD/mwccnlm BUILD/mwenv BUILD/mwldnlm \
BUILD/nwbootstrap BUILD/openssl.imp BUILD/save-patch
+endif
+
# Build init_db.sql from the files that contain
# the system tables for this version of MySQL plus any commands
@@ -103,9 +111,7 @@ init_db.sql: $(top_srcdir)/scripts/mysql_system_tables.sql \
test_db.sql: init_db.sql $(top_srcdir)/scripts/mysql_test_data_timezone.sql
@echo "Building $@";
@cat init_db.sql \
- $(top_srcdir)/scripts/mysql_test_data_timezone.sql >> $@;
-
-endif
+ $(top_srcdir)/scripts/mysql_test_data_timezone.sql > $@;
# Don't update the files from bitkeeper
%::SCCS/s.%