summaryrefslogtreecommitdiff
path: root/netware/Makefile.am
diff options
context:
space:
mode:
authorunknown <jani@ua141d10.elisa.omakaista.fi>2006-02-02 16:22:31 +0200
committerunknown <jani@ua141d10.elisa.omakaista.fi>2006-02-02 16:22:31 +0200
commitd497966a18acd0a9fa58615ebb8ba67cbebc89fc (patch)
treef474cf6a431a38ad063fdb2f0bf85385e3a7f970 /netware/Makefile.am
parentf0263ac452817f83d28047a20399fdef1e232e9a (diff)
downloadmariadb-git-d497966a18acd0a9fa58615ebb8ba67cbebc89fc.tar.gz
Several Netware specific fixes.
configure.in: To configure InnoDB for cross compilation. include/config-netware.h: NetWare specific change to fix the compilation errors caused by event.h NetWare specific change required for WINE PATH and for new versions LibC(Jun 05) and zlib(1.2.3) netware/BUILD/compile-AUTOTOOLS: Netware specific change reflecting the change in source code directory structure. netware/BUILD/compile-linux-tools: Netware specific change to fix the location where gen_lex_hash gets created. Fixed also directory structure reflecting changes. netware/BUILD/compile-netware-END: Netware specific change for creating mysqld_error.h netware/BUILD/mwenv: Netware specific change required for WINE PATH and for new versions LibC(Jun 05) and zlib(1.2.3). netware/BUILD/nwbootstrap: NetWare Specific change to produce absoulte path for XDC file. netware/Makefile.am: Netware specific changes to fix to match new directory structure. netware/my_manage.h: Netware specific change required for WINE PATH and for new versions LibC(Jun 05) and zlib(1.2.3). netware/mysql_test_run.c: Netware specific change, added --autoclose option for mysql_test_run.nlm. scripts/make_binary_distribution.sh: Fix to reflect change in directory structure. sql/mysqld.cc: Stacksize change for Netware. Netware specific change to fix the compilation errors caused by event.h sql/set_var.cc: Minor indending related fix. sql/sql_class.cc: Added #ifdef HAVE_EXPLICIT_TEMPLATE_INSTANTIATION macro. storage/innobase/os/os0thread.c: Netware specific change to increase the thread stack size. storage/myisam/mi_locking.c: Enclosed MMAP related code under HAVE_MMAP preprocessor directive.
Diffstat (limited to 'netware/Makefile.am')
-rw-r--r--netware/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/netware/Makefile.am b/netware/Makefile.am
index fdf4023aef2..e1c2eedc2b7 100644
--- a/netware/Makefile.am
+++ b/netware/Makefile.am
@@ -30,13 +30,16 @@ netware_build_files = client/mysql.def client/mysqladmin.def \
client/mysqldump.def client/mysqlimport.def \
client/mysqlshow.def client/mysqltest.def \
client/mysqlslap.def \
+ sql/mysqld.def extra/mysql_waitpid.def \
extra/mysql_install.def extra/my_print_defaults.def \
extra/perror.def extra/replace.def \
extra/resolveip.def extra/comp_err.def \
- libmysqld/libmysqld.def myisam/myisamchk.def \
- myisam/myisamlog.def myisam/myisampack.def \
- sql/mysqld.def extra/mysql_waitpid.def \
- extra/resolve_stack_dump.def myisam/myisam_ftdump.def
+ extra/resolve_stack_dump.def \
+ libmysqld/libmysqld.def \
+ storage/myisam/myisamchk.def \
+ storage/myisam/myisamlog.def \
+ storage/myisam/myisampack.def \
+ storage/myisam/myisam_ftdump.def
link_sources:
set -x; \