summaryrefslogtreecommitdiff
path: root/plugin/Makefile.am
diff options
context:
space:
mode:
authorJoerg Bruehe <joerg@mysql.com>2010-03-10 10:48:43 +0100
committerJoerg Bruehe <joerg@mysql.com>2010-03-10 10:48:43 +0100
commitc2676e2b5d237cd150cb38aa8aa241ed863bd556 (patch)
treeff0a31a6e578fe7d21c7f3e6a5d118675c6e31be /plugin/Makefile.am
parent35f5e9c78c25267c301212cfef757cfc933f9541 (diff)
downloadmariadb-git-c2676e2b5d237cd150cb38aa8aa241ed863bd556.tar.gz
Part of the fixes for bug#49022
Plugins included into bin release cannot be installed on debug version of server IF the build process was split into separate "debug" and "optimized" builds AND the plugin files of the debug build got copied into "plugin/debug/" (both is done for MySQL release builds starting from 5.5.3), THEN these debug plugin files are to be included in the final binary package. This change deals with the inclusion only, the other parts are done in different changesets.
Diffstat (limited to 'plugin/Makefile.am')
-rw-r--r--plugin/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/plugin/Makefile.am b/plugin/Makefile.am
index 68f1f939836..bddd0c929fc 100644
--- a/plugin/Makefile.am
+++ b/plugin/Makefile.am
@@ -1,4 +1,4 @@
-# Copyright (C) 2005-2006 MySQL AB
+# Copyright (c) 2005, 2010, Oracle and/or its affiliates. All rights reserved.
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -24,5 +24,10 @@ EXTRA_DIST = fulltext/configure.in
SUBDIRS = @mysql_pg_dirs@
DIST_SUBDIRS = @mysql_pg_distdirs@
+# As of 5.5.3-m3, we want to include the plugin files of a debug build in the package
+install-exec-hook:
+ $(mkinstalldirs) $(DESTDIR)$(pkglibdir) $(DESTDIR)$(pkglibdir)/plugin
+ test ! -d debug || $(TAR) cf - debug | ( cd $(DESTDIR)$(pkglibdir) && $(TAR) xvf - )
+
# Don't update the files from bitkeeper
%::SCCS/s.%