summaryrefslogtreecommitdiff
path: root/plugin/daemon_example/Makefile.am
diff options
context:
space:
mode:
authorbrian@zim.(none) <>2006-11-10 17:21:59 -0800
committerbrian@zim.(none) <>2006-11-10 17:21:59 -0800
commit739f2c27d0a9a05438218ed6977c18d044183772 (patch)
tree37454e0e0b2e40acf79f5fb9ee63b0cc5548d3c0 /plugin/daemon_example/Makefile.am
parent8a56fcff6a490ee67088682a5202802c21f8f0aa (diff)
downloadmariadb-git-739f2c27d0a9a05438218ed6977c18d044183772.tar.gz
This patch fixes the example engine, the example parser, and the example daemon to compile. AKA You can now test that the interface is actually working :)
Diffstat (limited to 'plugin/daemon_example/Makefile.am')
-rw-r--r--plugin/daemon_example/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/plugin/daemon_example/Makefile.am b/plugin/daemon_example/Makefile.am
new file mode 100644
index 00000000000..ccbada1be90
--- /dev/null
+++ b/plugin/daemon_example/Makefile.am
@@ -0,0 +1,21 @@
+#Makefile.am example for a daemon
+MYSQLDATAdir = $(localstatedir)
+MYSQLSHAREdir = $(pkgdatadir)
+MYSQLBASEdir= $(prefix)
+MYSQLLIBdir= $(pkglibdir)
+INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include \
+ -I$(srcdir)
+
+EXTRA_LTLIBRARIES = libdaemon_example.la
+pkglib_LTLIBRARIES = @plugin_daemon_example_shared_target@
+libdaemon_example_la_LDFLAGS = -module -rpath $(MYSQLLIBdir)
+libdaemon_example_la_CXXFLAGS= $(AM_CFLAGS) -DMYSQL_DYNAMIC_PLUGIN
+libdaemon_example_la_CFLAGS = $(AM_CFLAGS) -DMYSQL_DYNAMIC_PLUGIN
+libdaemon_example_la_SOURCES = daemon_example.c
+
+
+EXTRA_LIBRARIES = libdaemon_example.a
+noinst_LIBRARIES = @plugin_daemon_example_static_target@
+libdaemon_example_a_CXXFLAGS = $(AM_CFLAGS)
+libdaemon_example_a_CFLAGS = $(AM_CFLAGS)
+libdaemon_example_a_SOURCES= daemon_example.c