summaryrefslogtreecommitdiff
path: root/regex/Makefile.am
diff options
context:
space:
mode:
authorunknown <konstantin@mysql.com>2005-01-18 17:26:04 +0300
committerunknown <konstantin@mysql.com>2005-01-18 17:26:04 +0300
commitf3dbca5c738f061734cace5cab866c86bb34d3a9 (patch)
tree14b0fefd012f40431480d5310453e4df478456b7 /regex/Makefile.am
parent9ab94d6ca628851e01d022d53501a490048f0281 (diff)
downloadmariadb-git-f3dbca5c738f061734cace5cab866c86bb34d3a9.tar.gz
Cleanups in Makefile.ams
client/Makefile.am: Remove explicit _DEPENDENCIES, they are not needed with automatic dependency tracking wich we started using several months ago. Don't use relative paths in makefiles. regex/Makefile.am: Remove explicit _DEPENDENCIES, they are not needed with automatic dependency tracking wich we started using several months ago. Don't use relative paths. strings/Makefile.am: Remove dead rule.
Diffstat (limited to 'regex/Makefile.am')
-rw-r--r--regex/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/regex/Makefile.am b/regex/Makefile.am
index 2e23efcbf2a..ee7fc5463b7 100644
--- a/regex/Makefile.am
+++ b/regex/Makefile.am
@@ -17,12 +17,11 @@
INCLUDES = @MT_INCLUDES@ -I$(top_srcdir)/include
noinst_LIBRARIES = libregex.a
-LDADD = libregex.a ../strings/libmystrings.a
+LDADD= libregex.a $(top_builddir)/strings/libmystrings.a
noinst_HEADERS = cclass.h cname.h regex2.h utils.h engine.c regex.h
libregex_a_SOURCES = regerror.c regcomp.c regexec.c regfree.c reginit.c
noinst_PROGRAMS = re
re_SOURCES = split.c debug.c main.c
-re_DEPENDENCIES= $(LIBRARIES)
re_LDFLAGS= @NOINST_LDFLAGS@
EXTRA_DIST = tests CHANGES COPYRIGHT WHATSNEW regexp.c \
debug.ih engine.ih main.ih regcomp.ih regerror.ih \