summaryrefslogtreecommitdiff
path: root/scripts/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bruehe <joerg@mysql.com>2010-09-07 17:05:16 +0200
committerJoerg Bruehe <joerg@mysql.com>2010-09-07 17:05:16 +0200
commit9defb07e7dec05cbe899c8a63b7929f7232c37b6 (patch)
treeb2a4fe15893b037b0f5503f91dcf77620f0132d9 /scripts/CMakeLists.txt
parentf052fa3aad6b5720424f2f07a4e0175901f49b9e (diff)
downloadmariadb-git-9defb07e7dec05cbe899c8a63b7929f7232c37b6.tar.gz
Fix bug#56574:
After installation from RPM, server is run under root, not mysql user The problem was that in the cmake way of building the variable "MYSQLD_USER" was not set and propagated. In the script "mysqld_safe" its value is used as the name of the user who should run the server process. The fix is to explicitly set this variable to "mysql" and propagate it in the build process. It was analyzed and proposed by Jonathan Perkin.
Diffstat (limited to 'scripts/CMakeLists.txt')
-rw-r--r--scripts/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
index 4fc5f3f9b0d..0c9177c79c5 100644
--- a/scripts/CMakeLists.txt
+++ b/scripts/CMakeLists.txt
@@ -139,6 +139,7 @@ ELSE()
ENDIF()
SET(HOSTNAME "hostname")
+SET(MYSQLD_USER "mysql")
# Required for mysqlbug until autotools are deprecated, once done remove these
# and expand default cmake variables