summaryrefslogtreecommitdiff
path: root/scripts/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <vvaintroub@linux-rbsx>2010-01-18 21:19:24 +0100
committerVladislav Vaintroub <vvaintroub@linux-rbsx>2010-01-18 21:19:24 +0100
commitce59ee8098e22d99f402eea1b9d2d5de62a0caaf (patch)
tree01339fc7b0bf48a2b4b7527eb91dac753ec22381 /scripts/CMakeLists.txt
parent0ebe60070bed0b289b17e95de97ed34de9107e7f (diff)
downloadmariadb-git-ce59ee8098e22d99f402eea1b9d2d5de62a0caaf.tar.gz
Fix some problems found by kent.
-lm is sometimes not linked, which causes errors about undefined rint() - FreeBSD embedded library does not link with the flags returned by mysql_config (added -lcrypt to LIBS, whereby causing overlinking in case of normal non-embedded client)
Diffstat (limited to 'scripts/CMakeLists.txt')
-rwxr-xr-xscripts/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
index 98fa00d01ea..0b574fc0621 100755
--- a/scripts/CMakeLists.txt
+++ b/scripts/CMakeLists.txt
@@ -216,6 +216,10 @@ ENDIF()
SET(LIBS "${CLIENT_LIBS}")
+IF(LIBCRYPT)
+ SET(LIBS "${LIBS} -l${LIBCRYPT}")
+ENDIF()
+
IF(MSVC)
STRING(REPLACE "-l" "" CLIENT_LIBS "${CLIENT_LIBS}")
STRING(REPLACE "-l" "" LIBS "${LIBS}" )