summaryrefslogtreecommitdiff
path: root/scripts/CMakeLists.txt
diff options
context:
space:
mode:
authorKent Boortz <kent.boort@sun.com>2010-04-27 22:21:48 +0200
committerKent Boortz <kent.boort@sun.com>2010-04-27 22:21:48 +0200
commit242600b7a7786bfc453ab7be6633de7da046abd0 (patch)
tree7feef8fa0d7e6d3045a047c0d9621e58da21db6c /scripts/CMakeLists.txt
parentd632d01137b4cf358c8577af12c83dfbdde12d05 (diff)
downloadmariadb-git-242600b7a7786bfc453ab7be6633de7da046abd0.tar.gz
On Mac OS X, add the "-arch" option to the 'mysql_config' output
Diffstat (limited to 'scripts/CMakeLists.txt')
-rwxr-xr-xscripts/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
index bfe65a0acd8..7f7baecc6c1 100755
--- a/scripts/CMakeLists.txt
+++ b/scripts/CMakeLists.txt
@@ -93,6 +93,10 @@ IF(CMAKE_GENERATOR MATCHES "Makefiles")
# No multiconfig build - use CMAKE_C_FLAGS
SET(CFLAGS "@CMAKE_C_FLAGS@")
SET(CXXFLAGS "@CMAKE_CXX_FLAGS@")
+ FOREACH(ARCH ${CMAKE_OSX_ARCHITECTURES})
+ SET(CFLAGS "${CFLAGS} -arch ${ARCH}")
+ SET(CXXFLAGS "${CXXFLAGS} -arch ${ARCH}")
+ ENDFOREACH()
ELSE()
# Multiconfig build - use CMAKE_C_FLAGS_RELWITHDEBINFO
SET(CFLAGS "@CMAKE_C_FLAGS_RELWITHDEBINFO@")