summaryrefslogtreecommitdiff
path: root/scripts/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Widenius <monty@askmonty.org>2011-06-27 19:30:05 +0300
committerMichael Widenius <monty@askmonty.org>2011-06-27 19:30:05 +0300
commitc785ed70a9fe1d55d332ab36c139587592f3fbe5 (patch)
treea2f15e4950f009a28e4cf70e1e18ebfc09e0e73e /scripts/CMakeLists.txt
parentba9a890f0c389a93925c8c21a30e64801f397f18 (diff)
downloadmariadb-git-c785ed70a9fe1d55d332ab36c139587592f3fbe5.tar.gz
Added mytop to distribution (with some small trivial changes to make it workg good also for MariaDB)
scripts/CMakeLists.txt: Added mytop scripts/Makefile.am: Added mytop scripts/make_binary_distribution.sh: Added mytop scripts/make_win_bin_dist: Added mytop scripts/mytop.sh: Added mytop (with some small trivial changes to make it workg good also for MariaDB) support-files/mysql.spec.sh: Added mytop
Diffstat (limited to 'scripts/CMakeLists.txt')
-rwxr-xr-xscripts/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
index a62569843db..d0cbafccc82 100755
--- a/scripts/CMakeLists.txt
+++ b/scripts/CMakeLists.txt
@@ -80,7 +80,10 @@ CONFIGURE_FILE(mysqldumpslow.sh
CONFIGURE_FILE(mysqlhotcopy.sh
${CMAKE_BINARY_DIR}/scripts/mysqlhotcopy.pl ESCAPE_QUOTES @ONLY)
-FOREACH(f mysqldumpslow.pl mysqlhotcopy.pl mysql_config.pl
+CONFIGURE_FILE(mytop.sh
+ ${CMAKE_BINARY_DIR}/scripts/mytop.pl ESCAPE_QUOTES @ONLY)
+
+FOREACH(f mysqldumpslow.pl mysqlhotcopy.pl mytop.pl mysql_config.pl
mysql_convert_table_format.pl mysql_install_db.pl
mysql_secure_installation.pl mysqld_multi.pl)
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/${f}
@@ -90,4 +93,4 @@ ENDFOREACH()
INSTALL(FILES fill_help_tables.sql mysql_system_tables.sql
mysql_system_tables_data.sql mysql_system_tables_fix.sql mysql_test_data_timezone.sql
DESTINATION share COMPONENT Server)
-INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mysql_fix_privilege_tables.sql DESTINATION share COMPONENT Server) \ No newline at end of file
+INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mysql_fix_privilege_tables.sql DESTINATION share COMPONENT Server)