summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorunknown <msvensson@pilot.blaudden>2007-02-28 14:26:58 +0100
committerunknown <msvensson@pilot.blaudden>2007-02-28 14:26:58 +0100
commit838e89dea60b7215a39c80824764d92f951dd5c4 (patch)
tree6d9ef281e8fe580bf7b58a5e481dde0fd7a5c123 /scripts/Makefile.am
parentdda46f74f0f9a69e20a7647bf76c5c3d1752f20f (diff)
downloadmariadb-git-838e89dea60b7215a39c80824764d92f951dd5c4.tar.gz
Bug#20166 mysql-test-run.pl does not test system privilege tables creation
- Split out initial data in mysql_system_tables.sql to it's own file - Use file from mysql_install_db and mysql-test-run scripts/mysql_system_tables_fix.sql: Rename: scripts/mysql_fix_privilege_tables.sql.in -> scripts/mysql_system_tables_fix.sql mysql-test/mysql-test-run.pl: - Add mysql_system_tables_data.sql as part of the bootstrap - Remove the addition of pid to end of bootstrap.sql, now to file used for bootstrap will be $opt_vardir/tmp/bootstrap.sql - Improve error message descibing how to find cause of a failed bootstrap scripts/Makefile.am: - Rename mysql_fix_privileg_tables.sql.in to mysql_system_tables_fix.sql - Build mysql_fix_privilege_tables from mysql_system_tables.sql and mysql_system_tables_fix.sql - Add mysql_system_tables_fix.sql to EXTRA_DIST scripts/mysql_install_db.sh: - Use mysql_system_tables_data.sql file when bootstrapping mysql, it will contain initial data for MysQL system tables scripts/mysql_system_tables.sql: Move initial data for system tables to it's own file scripts/mysql_system_tables_data.sql: Move initial data for system tables to it's own file
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index d1c3bd82050..cca81cd8818 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -65,15 +65,14 @@ EXTRA_DIST = $(EXTRA_SCRIPTS) \
mysqlaccess.conf \
mysqlbug \
make_win_bin_dist \
- mysql_fix_privilege_tables.sql.in
+ mysql_system_tables_fix.sql
dist_pkgdata_DATA = fill_help_tables.sql \
mysql_fix_privilege_tables.sql \
mysql_system_tables.sql \
+ mysql_system_tables_data.sql \
mysql_test_data_timezone.sql
-# mysqlbug should be distributed built so that people can report build
-# failures with it.
CLEANFILES = @server_scripts@ \
make_binary_distribution \
make_sharedlib_distribution \
@@ -94,8 +93,11 @@ CLEANFILES = @server_scripts@ \
mysql_upgrade_shell \
mysqld_multi \
make_win_src_distribution \
- mysql_create_system_tables
+ mysql_create_system_tables \
+ mysql_fix_privilege_tables.sql
+# mysqlbug should be distributed built so that people can report build
+# failures with it.
DISTCLEANFILES = mysqlbug
# We want the right version and configure comand line in mysqlbug
@@ -104,10 +106,10 @@ mysqlbug: ${top_builddir}/config.status mysqlbug.sh
# Build mysql_fix_privilege_tables.sql from the files that contain
# the system tables for this version of MySQL plus any commands
# needed to upgrade the system tables from an older version
-mysql_fix_privilege_tables.sql: mysql_fix_privilege_tables.sql.in \
- mysql_system_tables.sql
+mysql_fix_privilege_tables.sql: mysql_system_tables.sql \
+ mysql_system_tables_fix.sql
@echo "Building $@";
- @cat mysql_system_tables.sql $@.in > $@
+ @cat mysql_system_tables.sql mysql_system_tables_fix.sql > $@
SUFFIXES = .sh