summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorunknown <msvensson@pilot.blaudden>2007-04-23 14:01:48 +0200
committerunknown <msvensson@pilot.blaudden>2007-04-23 14:01:48 +0200
commitb44eee2a6739afb44f59a06c2f7adb309f66b6a9 (patch)
tree6dcdf535a8395ea3fc572f84b12eb31c53f45e35 /scripts/Makefile.am
parent09e6e6618ffb744899d6a45ae8987412cea51cdb (diff)
downloadmariadb-git-b44eee2a6739afb44f59a06c2f7adb309f66b6a9.tar.gz
Add "name of struct" as first arg to comp_sql
Fix "make distcheck" scripts/CMakeLists.txt: Add "name of struct" as first arg to comp_sql scripts/comp_sql.c: Add "name of struct" as first arg to comp_sql
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am32
1 files changed, 18 insertions, 14 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index e9398fc1a72..79f4666f855 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -15,6 +15,11 @@
## Process this file with automake to create Makefile.in
+BUILT_SOURCES = mysql_fix_privilege_tables.sql \
+ mysql_fix_privilege_tables_sql.c
+
+noinst_PROGRAMS = comp_sql
+
bin_SCRIPTS = @server_scripts@ \
msql2mysql \
mysql_config \
@@ -94,7 +99,8 @@ CLEANFILES = @server_scripts@ \
mysql_upgrade_shell \
mysqld_multi \
make_win_src_distribution \
- mysql_fix_privilege_tables.sql
+ mysql_fix_privilege_tables.sql \
+ mysql_fix_privilege_tables_sql.c
# mysqlbug should be distributed built so that people can report build
# failures with it.
@@ -111,6 +117,17 @@ mysql_fix_privilege_tables.sql: mysql_system_tables.sql \
@echo "Building $@";
@cat mysql_system_tables.sql mysql_system_tables_fix.sql > $@
+#
+# Build mysql_fix_privilege_tables_sql.c from
+# mysql_fix_privileges_tables.sql using comp_sql
+#
+mysql_fix_privilege_tables_sql.c: comp_sql.c mysql_fix_privilege_tables.sql
+ $(MAKE) $(AM_MAKEFLAGS) comp_sql$(EXEEXT)
+ $(top_builddir)/scripts/comp_sql$(EXEEXT) \
+ mysql_fix_privilege_tables \
+ $(top_srcdir)/scripts/mysql_fix_privilege_tables.sql $@
+
+
SUFFIXES = .sh
.sh:
@@ -167,18 +184,5 @@ SUFFIXES = .sh
@MV@ $@-t $@
-BUILT_SOURCES = mysql_fix_privilege_tables_sql.c
-noinst_PROGRAMS = comp_sql
-
-#
-# Build mysql_fix_privilege_tables_sql.c from
-# mysql_fix_privileges_tables.sql using comp_sql
-#
-mysql_fix_privilege_tables_sql.c: comp_sql.c mysql_fix_privilege_tables.sql
- $(MAKE) $(AM_MAKEFLAGS) comp_sql$(EXEEXT)
- $(top_builddir)/scripts/comp_sql$(EXEEXT) \
- mysql_fix_privilege_tables.sql $@
-
-
# Don't update the files from bitkeeper
%::SCCS/s.%