summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@mysql.com/kent-amd64.(none)>2007-09-27 12:21:56 +0200
committerunknown <kent@mysql.com/kent-amd64.(none)>2007-09-27 12:21:56 +0200
commit3e95b39882ba06e0d165027b9b08c210241bc531 (patch)
tree3e9522d269dbbe5881e6ee49c08e677307d5beaf /scripts/Makefile.am
parent13bd3dbff2076109a26a4f081093cada7dc0bcac (diff)
downloadmariadb-git-3e95b39882ba06e0d165027b9b08c210241bc531.tar.gz
Makefile.am, make_binary_distribution.sh:
Use custom 'pkgduppdir' mysql.server.sh: The server is installed in 'libexecdir' scripts/Makefile.am: Use custom 'pkgduppdir' scripts/make_binary_distribution.sh: Use custom 'pkgduppdir' support-files/mysql.server.sh: The server is installed in 'libexecdir'
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 471a23f0a73..fed96490397 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -90,6 +90,9 @@ CLEANFILES = @server_scripts@ \
mysql_tableinfo \
mysqld_multi
+# Default same as 'pkgdatadir', but we can override it
+pkgsuppdir = $(datadir)/@PACKAGE@
+
# mysqlbug should be distributed built so that people can report build
# failures with it.
DISTCLEANFILES = $(BUILT_SOURCES) mysqlbug
@@ -134,6 +137,7 @@ SUFFIXES = .sh
-e 's!@''pkglibdir''@!$(pkglibdir)!g' \
-e 's!@''pkgincludedir''@!$(pkgincludedir)!g' \
-e 's!@''pkgdatadir''@!$(pkgdatadir)!g' \
+ -e 's!@''pkgsuppdir''@!$(pkgsuppdir)!g' \
-e 's!@''sysconfdir''@!$(sysconfdir)!g' \
-e 's!@''mandir''@!$(mandir)!g' \
-e 's!@''infodir''@!$(infodir)!g' \