summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorunknown <joerg@trift2.>2007-05-03 15:51:02 +0200
committerunknown <joerg@trift2.>2007-05-03 15:51:02 +0200
commitad33a48afc21c7c89e7ea893ea826e305bd09258 (patch)
tree6fc9a70edeb68226b38e79f2a441287fec07928e /scripts/Makefile.am
parentdc39e2c20ef7c20d1e6965e345b48f06d122477b (diff)
downloadmariadb-git-ad33a48afc21c7c89e7ea893ea826e305bd09258.tar.gz
Better distinction between "CLEANFILES" and "DISTCLEANFILES" for some generated files
(here: "scripts/mysql_fix_privilege_tables{.sql,_sql.c}"). Important for cross-builds. scripts/Makefile.am: Generated files like "mysql_fix_privilege_tables{.sql,_sql.c}" should survive a "make clean", this is essential for cross-builds. So move them from "CLEANFILES" to "DISTCLEANFILES".
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am14
1 files changed, 6 insertions, 8 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 754ca2ea4c0..d4944962884 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -16,7 +16,7 @@
## Process this file with automake to create Makefile.in
BUILT_SOURCES = mysql_fix_privilege_tables.sql \
- mysql_fix_privilege_tables_sql.c
+ mysql_fix_privilege_tables_sql.c
EXTRA_PROGRAMS = comp_sql
@@ -70,7 +70,6 @@ EXTRA_DIST = $(EXTRA_SCRIPTS) \
mysqlaccess.conf \
mysqlbug \
make_win_bin_dist \
- mysql_fix_privilege_tables.sql \
mysql_fix_privilege_tables_sql.c \
mysql_system_tables_fix.sql \
CMakeLists.txt
@@ -100,13 +99,11 @@ CLEANFILES = @server_scripts@ \
mysql_tableinfo \
mysql_upgrade_shell \
mysqld_multi \
- make_win_src_distribution \
- mysql_fix_privilege_tables.sql \
- mysql_fix_privilege_tables_sql.c
+ make_win_src_distribution
# mysqlbug should be distributed built so that people can report build
# failures with it.
-DISTCLEANFILES = mysqlbug
+DISTCLEANFILES = $(BUILT_SOURCES) mysqlbug
# We want the right version and configure comand line in mysqlbug
mysqlbug: ${top_builddir}/config.status mysqlbug.sh
@@ -122,11 +119,12 @@ mysql_fix_privilege_tables.sql: mysql_system_tables.sql \
#
# Build mysql_fix_privilege_tables_sql.c from
# mysql_fix_privileges_tables.sql using comp_sql
-# The "sleep" ensures the generated file has a younger timestamp than its source.
+# The "sleep" ensures the generated file has a younger timestamp than its source
+# (which may have been generated in this very same "make" run).
#
mysql_fix_privilege_tables_sql.c: comp_sql.c mysql_fix_privilege_tables.sql
$(MAKE) $(AM_MAKEFLAGS) comp_sql$(EXEEXT)
- sleep 5
+ sleep 2
$(top_builddir)/scripts/comp_sql$(EXEEXT) \
mysql_fix_privilege_tables \
$(top_srcdir)/scripts/mysql_fix_privilege_tables.sql $@