summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorunknown <monty@narttu.mysql.fi>2003-03-21 18:53:55 +0200
committerunknown <monty@narttu.mysql.fi>2003-03-21 18:53:55 +0200
commite4ae47ff36894c6c776a26b16141cec5eddb34b0 (patch)
treece48d336533b0ff442f6fd114d61fffcfbdc1941 /scripts/Makefile.am
parent75ad5e96e1d7b504e7a0372fd8632c047ac2336f (diff)
downloadmariadb-git-e4ae47ff36894c6c776a26b16141cec5eddb34b0.tar.gz
Fixes for fill_help_tables.sql
innobase/ha/ha0ha.c: Removed compiler warnings mysql-test/t/innodb.test: Another fix for cardinality scripts/Makefile.am: Install fill_help_tables.sql in prefix/share/mysql Don't install make_binary_distribution scripts/fill_help_tables.sh: use INSERT IGNORE to avoid errors scripts/make_binary_distribution.sh: Install and use fill_help_tables.sql scripts/mysql_install_db.sh: Search for and use fill_help_tables.sql sql/mysqld.cc: Don't write shutdown message when called from mysql_install_db support-files/Makefile.am: Don't install binary-configure support-files/binary-configure.sh: Don't use config files
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am19
1 files changed, 12 insertions, 7 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 3b4d19b7eed..88f561e0e6d 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -58,10 +58,9 @@ EXTRA_SCRIPTS = make_binary_distribution.sh \
EXTRA_DIST = $(EXTRA_SCRIPTS) \
mysqlaccess.conf \
- mysqlbug \
- fill_help_tables.sql
+ mysqlbug
-pkgdata_DATA = make_binary_distribution
+pkgdata_DATA = fill_help_tables.sql
# mysqlbug should be distributed built so that people can report build
# failures with it.
@@ -81,8 +80,8 @@ CLEANFILES = @server_scripts@ \
mysqlhotcopy \
mysqldumpslow \
mysqld_multi \
- fill_help_tables \
- fill_help_tables.sql
+ fill_help_tables \
+ fill_help_tables.sql
SUPERCLEANFILES = mysqlbug
@@ -103,6 +102,7 @@ SUFFIXES = .sh
-e 's!@''libexecdir''@!$(libexecdir)!g' \
-e 's!@''pkglibdir''@!$(pkglibdir)!g' \
-e 's!@''pkgincludedir''@!$(pkgincludedir)!g' \
+ -e 's!@''pkgdatadir''@!$(pkgdatadir)!g' \
-e 's!@''CC''@!@CC@!'\
-e 's!@''CXX''@!@CXX@!'\
-e 's!@''GXX''@!@GXX@!'\
@@ -137,7 +137,12 @@ SUFFIXES = .sh
# Don't update the files from bitkeeper
%::SCCS/s.%
-all: fill_help_tables.sql make_win_src_distribution
+all: fill_help_tables.sql make_win_src_distribution make_binary_distribution
+
+# The following rule is here to ensure that build will continue
+# even if we don't have perl installed. In this case the help tables
+# will be empty
fill_help_tables.sql: fill_help_tables ../Docs/manual.texi
- ./fill_help_tables < ../Docs/manual.texi > fill_help_tables.sql
+ -./fill_help_tables < ../Docs/manual.texi > fill_help_tables.sql
+ echo "" >> fill_help_tables.sql