summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorunknown <joerg@trift2.>2007-05-02 20:07:01 +0200
committerunknown <joerg@trift2.>2007-05-02 20:07:01 +0200
commit2478a8be0c3d438119b3c024822a61a69ea972ce (patch)
tree7c096f59c5eba613d2b8e6d2a65ac927b361f454 /scripts/Makefile.am
parent2f2f11b3decd112c7549cdc95df5098685c07c6f (diff)
downloadmariadb-git-2478a8be0c3d438119b3c024822a61a69ea972ce.tar.gz
Resolve a possible timing issue with "scripts/mysql_fix_privilege_tables_sql.c" in the
source tarball, this is essential for cross builds, like for NetWare. scripts/Makefile.am: On a fast build machine, both the source (mysql_fix_privilege_tables.sql) and the generated file (mysql_fix_privilege_tables_sql.c) may have identical timestamps (granularity is one second only, may be too coarse). If that happens, the Makefile rule will fire, and "comp_sql" will be built and called - which fails in a cross build, like for NetWare. Prevent that by sleeping for 5 (five) seconds, this will ensure a time difference.
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index cb0658f8756..754ca2ea4c0 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -122,9 +122,11 @@ mysql_fix_privilege_tables.sql: mysql_system_tables.sql \
#
# Build mysql_fix_privilege_tables_sql.c from
# mysql_fix_privileges_tables.sql using comp_sql
+# The "sleep" ensures the generated file has a younger timestamp than its source.
#
mysql_fix_privilege_tables_sql.c: comp_sql.c mysql_fix_privilege_tables.sql
$(MAKE) $(AM_MAKEFLAGS) comp_sql$(EXEEXT)
+ sleep 5
$(top_builddir)/scripts/comp_sql$(EXEEXT) \
mysql_fix_privilege_tables \
$(top_srcdir)/scripts/mysql_fix_privilege_tables.sql $@