summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorunknown <msvensson@pilot.blaudden>2007-02-28 14:41:57 +0100
committerunknown <msvensson@pilot.blaudden>2007-02-28 14:41:57 +0100
commitc664530d7083c5faf23d771fe384856f090b73c0 (patch)
treee99b55b8792517d9010a35f65ac70991407ea168 /scripts/Makefile.am
parente9cce1793dafdaf6d5c085d352d82cc0d3026004 (diff)
parent838e89dea60b7215a39c80824764d92f951dd5c4 (diff)
downloadmariadb-git-c664530d7083c5faf23d771fe384856f090b73c0.tar.gz
Merge pilot.blaudden:/home/msvensson/mysql/mysql-5.0-maint-bug20166
into pilot.blaudden:/home/msvensson/mysql/mysql-5.1-new-maint mysql-test/mysql-test-run.pl: Auto merged scripts/Makefile.am: Auto merged scripts/mysql_install_db.sh: Auto merged scripts/mysql_system_tables_fix.sql: Auto merged scripts/mysql_system_tables.sql: Manual merge
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 4ba81d7f168..dc0c1396a44 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -57,15 +57,14 @@ EXTRA_DIST = $(EXTRA_SCRIPTS) \
mysqlaccess.conf \
mysqlbug \
make_win_bin_dist \
- mysql_fix_privilege_tables.sql.in
+ mysql_system_tables_fix.sql
dist_pkgdata_DATA = fill_help_tables.sql \
mysql_fix_privilege_tables.sql \
mysql_system_tables.sql \
+ mysql_system_tables_data.sql \
mysql_test_data_timezone.sql
-# mysqlbug should be distributed built so that people can report build
-# failures with it.
CLEANFILES = @server_scripts@ \
make_binary_distribution \
make_sharedlib_distribution \
@@ -83,8 +82,11 @@ CLEANFILES = @server_scripts@ \
mysqldumpslow \
mysql_tableinfo \
mysqld_multi \
- mysql_create_system_tables
+ mysql_create_system_tables \
+ mysql_fix_privilege_tables.sql
+# mysqlbug should be distributed built so that people can report build
+# failures with it.
DISTCLEANFILES = mysqlbug
# We want the right version and configure comand line in mysqlbug
@@ -93,10 +95,10 @@ mysqlbug: ${top_builddir}/config.status mysqlbug.sh
# Build mysql_fix_privilege_tables.sql from the files that contain
# the system tables for this version of MySQL plus any commands
# needed to upgrade the system tables from an older version
-mysql_fix_privilege_tables.sql: mysql_fix_privilege_tables.sql.in \
- mysql_system_tables.sql
+mysql_fix_privilege_tables.sql: mysql_system_tables.sql \
+ mysql_system_tables_fix.sql
@echo "Building $@";
- @cat mysql_system_tables.sql $@.in > $@
+ @cat mysql_system_tables.sql mysql_system_tables_fix.sql > $@
SUFFIXES = .sh