summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorunknown <joerg@trift2.>2007-04-30 17:01:00 +0200
committerunknown <joerg@trift2.>2007-04-30 17:01:00 +0200
commitc2dc7d92ac854d4c4f40b73f5836448dbf2280fb (patch)
treee0a6f8256f89d0d847f403fcaf3bba4dac9b48b3 /scripts/Makefile.am
parentc8b4b9e36b292ba262cecfdde2e56040e648d794 (diff)
downloadmariadb-git-c2dc7d92ac854d4c4f40b73f5836448dbf2280fb.tar.gz
Necessary change for cross-builds: Include "mysql_fix_privilege_tables_sql.c" in the source tarball.
scripts/Makefile.am: Necessary change for cross-builds (like we do for NetWare): Generate "mysql_fix_privilege_tables_sql.c" during Bootstrap and include it in the source tarball which is created via "make dist".
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 79f4666f855..52c1b6140d3 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -18,7 +18,7 @@
BUILT_SOURCES = mysql_fix_privilege_tables.sql \
mysql_fix_privilege_tables_sql.c
-noinst_PROGRAMS = comp_sql
+EXTRA_PROGRAMS = comp_sql
bin_SCRIPTS = @server_scripts@ \
msql2mysql \
@@ -70,6 +70,8 @@ EXTRA_DIST = $(EXTRA_SCRIPTS) \
mysqlaccess.conf \
mysqlbug \
make_win_bin_dist \
+ mysql_fix_privilege_tables.sql \
+ mysql_fix_privilege_tables_sql.c \
mysql_system_tables_fix.sql \
CMakeLists.txt