summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorunknown <vva@eagle.mysql.r18.ru>2003-05-29 17:47:31 -0400
committerunknown <vva@eagle.mysql.r18.ru>2003-05-29 17:47:31 -0400
commit69e084af1eedff2dda70fcf073dd4fa349718b69 (patch)
treea9f85257a75430a22735e52666cbf25e605ea2bb /scripts/Makefile.am
parentf440077bd03869f48ff278bc2b73fab7a30e282b (diff)
downloadmariadb-git-69e084af1eedff2dda70fcf073dd4fa349718b69.tar.gz
new version of help
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am20
1 files changed, 7 insertions, 13 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 88f561e0e6d..1134226bfaf 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -32,7 +32,9 @@ bin_SCRIPTS = @server_scripts@ \
mysqldumpslow \
mysql_explain_log \
mysql_tableinfo \
- mysqld_multi
+ mysqld_multi \
+ fill_help_tables \
+ mysql_create_system_tables
EXTRA_SCRIPTS = make_binary_distribution.sh \
make_win_src_distribution.sh \
@@ -54,14 +56,13 @@ EXTRA_SCRIPTS = make_binary_distribution.sh \
mysqld_multi.sh \
mysql_tableinfo.sh \
mysqld_safe.sh \
- fill_help_tables.sh
+ fill_help_tables.sh \
+ mysql_create_system_tables.sh
EXTRA_DIST = $(EXTRA_SCRIPTS) \
mysqlaccess.conf \
mysqlbug
-pkgdata_DATA = fill_help_tables.sql
-
# mysqlbug should be distributed built so that people can report build
# failures with it.
CLEANFILES = @server_scripts@ \
@@ -81,7 +82,7 @@ CLEANFILES = @server_scripts@ \
mysqldumpslow \
mysqld_multi \
fill_help_tables \
- fill_help_tables.sql
+ mysql_create_system_tables
SUPERCLEANFILES = mysqlbug
@@ -137,12 +138,5 @@ SUFFIXES = .sh
# Don't update the files from bitkeeper
%::SCCS/s.%
-all: fill_help_tables.sql make_win_src_distribution make_binary_distribution
-
-# The following rule is here to ensure that build will continue
-# even if we don't have perl installed. In this case the help tables
-# will be empty
+all: make_win_src_distribution make_binary_distribution
-fill_help_tables.sql: fill_help_tables ../Docs/manual.texi
- -./fill_help_tables < ../Docs/manual.texi > fill_help_tables.sql
- echo "" >> fill_help_tables.sql