summaryrefslogtreecommitdiff
path: root/server-tools/instance-manager/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@mysql.com>2006-02-09 03:11:45 +0100
committerunknown <kent@mysql.com>2006-02-09 03:11:45 +0100
commite653fbc322fd06b6350e848b3675faee3c05ce42 (patch)
treed4e46dedd64e47753467d4e861b00d83399ae1ec /server-tools/instance-manager/Makefile.am
parentbfcd35e923e0f7586d59d273b670f0e95babe16d (diff)
downloadmariadb-git-e653fbc322fd06b6350e848b3675faee3c05ce42.tar.gz
Makefile.am:
Link with CLIENT_EXTRA_LDFLAGS, enable us to pass on libtool flags '-full-static' and '-static' using '--with-client-ldflags' to configure. mysql.spec.sh: Pass '-static' to libtool, link static with our own libraries, dynamic with system libraries. Link with the bundled zlib. support-files/mysql.spec.sh: Pass '-static' to libtool, link static with our own libraries, dynamic with system libraries. Link with the bundled zlib. server-tools/instance-manager/Makefile.am: Link with CLIENT_EXTRA_LDFLAGS, enable us to pass on libtool flags '-full-static' and '-static' using '--with-client-ldflags' to configure.
Diffstat (limited to 'server-tools/instance-manager/Makefile.am')
-rw-r--r--server-tools/instance-manager/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/server-tools/instance-manager/Makefile.am b/server-tools/instance-manager/Makefile.am
index 7449735f0bf..7afadf03ec1 100644
--- a/server-tools/instance-manager/Makefile.am
+++ b/server-tools/instance-manager/Makefile.am
@@ -79,7 +79,8 @@ mysqlmanager_SOURCES= command.cc command.h mysqlmanager.cc \
mysql_manager_error.h \
portability.h
-mysqlmanager_LDADD= liboptions.a \
+mysqlmanager_LDADD= @CLIENT_EXTRA_LDFLAGS@ \
+ liboptions.a \
libnet.a \
$(top_builddir)/vio/libvio.a \
$(top_builddir)/mysys/libmysys.a \