summaryrefslogtreecommitdiff
path: root/sql-common/Makefile.am
diff options
context:
space:
mode:
authorunknown <anozdrin@mysql.com>2006-01-11 02:07:40 +0300
committerunknown <anozdrin@mysql.com>2006-01-11 02:07:40 +0300
commitd4d29edb836c697d744bb75496b58b76554fcb68 (patch)
tree2d2fbf7237a87334eb708a2f4af55c8b443046df /sql-common/Makefile.am
parentffc206d9be17b67f1daed509e5939c63519960f0 (diff)
downloadmariadb-git-d4d29edb836c697d744bb75496b58b76554fcb68.tar.gz
Fix for BUG#15110: mysqldump --triggers: does not include DEFINER clause
There are two main idea of this fix: - introduce a common function for server and client to split user value (<user name>@<host name>) into user name and host name parts; - dump DEFINER clause in correct format in mysqldump. BitKeeper/etc/ignore: added client/my_user.c libmysqld/my_user.c sql/my_user.c client/Makefile.am: Use my_user.c in linking of mysqldump executable. client/mysqldump.c: Fix for BUG#15110(mysqldump --triggers: does not include DEFINER clause) include/Makefile.am: Add my_user.c include/mysql_com.h: Introduce a constant for max user length. libmysqld/Makefile.am: Add my_user.c mysql-test/r/mysqldump.result: Update result file. sql-common/Makefile.am: Add my_user.c sql/Makefile.am: Add my_user.c sql/sp.cc: Use constant for max user length. sql/sp_head.cc: Use common function to parse user value. sql/sql_acl.cc: Use constant for max user length. sql/sql_parse.cc: Use constant for max user length. sql/sql_show.cc: Use constant for max user length. sql/sql_trigger.cc: Use constant for max user length. include/my_user.h: A header file for parse_user(). sql-common/my_user.c: A new file for parse_user() implementation.
Diffstat (limited to 'sql-common/Makefile.am')
-rw-r--r--sql-common/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/sql-common/Makefile.am b/sql-common/Makefile.am
index 6bd42d70e4f..d71523a741c 100644
--- a/sql-common/Makefile.am
+++ b/sql-common/Makefile.am
@@ -15,7 +15,7 @@
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
## Process this file with automake to create Makefile.in
-EXTRA_DIST = client.c pack.c my_time.c
+EXTRA_DIST = client.c pack.c my_time.c my_user.c
# Don't update the files from bitkeeper
%::SCCS/s.%