summaryrefslogtreecommitdiff
path: root/sql/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <wlad@montyprogram.com>2012-04-15 01:29:17 +0200
committerVladislav Vaintroub <wlad@montyprogram.com>2012-04-15 01:29:17 +0200
commit87b6f241064beb8f94669ba438e8c9c479016e76 (patch)
treeffe537bb8e95693f11f635b16bd9336983b7e983 /sql/CMakeLists.txt
parentf18514df2ea2a04c3c03625531935f7703fc98f3 (diff)
downloadmariadb-git-87b6f241064beb8f94669ba438e8c9c479016e76.tar.gz
Use test/db.opt as dummy file in the package, instead of test/.empty
Also, do not package aria log files in the zip package- not required for the database to function, also will avoid trouble with recovery, if someone accidentially (or on purpose) upgrades by unpacking the zip in the existing install directory.
Diffstat (limited to 'sql/CMakeLists.txt')
-rw-r--r--sql/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/sql/CMakeLists.txt b/sql/CMakeLists.txt
index 446db5d128a..0e64487e24f 100644
--- a/sql/CMakeLists.txt
+++ b/sql/CMakeLists.txt
@@ -271,7 +271,7 @@ IF(INSTALL_LAYOUT STREQUAL "STANDALONE")
# We need to create empty directories (data/test) the installation.
# This does not work with current CPack due to http://www.cmake.org/Bug/view.php?id=8767
# Avoid completely empty directories and install dummy file instead.
-SET(DUMMY_FILE ${CMAKE_CURRENT_BINARY_DIR}/.empty )
+SET(DUMMY_FILE ${CMAKE_CURRENT_BINARY_DIR}/db.opt )
FILE(WRITE ${DUMMY_FILE} "")
INSTALL(FILES ${DUMMY_FILE} DESTINATION data/test COMPONENT DataFiles)
@@ -303,7 +303,11 @@ IF(WIN32 AND MYSQLD_EXECUTABLE)
DEPENDS initdb.dep
)
INSTALL(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/data DESTINATION .
- COMPONENT DataFiles PATTERN "initdb.dep" EXCLUDE PATTERN "bootstrap.sql" EXCLUDE)
+ COMPONENT DataFiles
+ PATTERN "initdb.dep" EXCLUDE
+ PATTERN "bootstrap.sql" EXCLUDE
+ PATTERN "aria*" EXCLUDE
+ )
ELSE()
# Not windows or cross compiling, just install an empty directory
INSTALL(FILES ${DUMMY_FILE} DESTINATION data/mysql COMPONENT DataFiles)