summaryrefslogtreecommitdiff
path: root/sql/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <wlad@montyprogram.com>2012-03-15 00:37:37 +0100
committerVladislav Vaintroub <wlad@montyprogram.com>2012-03-15 00:37:37 +0100
commitd110e0377dda1bb9f5a5c36745d3a6feb8e8a1d4 (patch)
treebd61f8e0207c7ec18376c21b89e4418879bea160 /sql/CMakeLists.txt
parentc3c14a069b53968bbb47fda7adabd4947c272996 (diff)
downloadmariadb-git-d110e0377dda1bb9f5a5c36745d3a6feb8e8a1d4.tar.gz
Fix compile error - linker does not find extern variables, in sql_logger.c
The file uses external variables defined in another (C++) source file. Since MSVC mangles variables and not only functions, either variables in question should be extern "C", or sql_logger should be made C++ for link to succeed. Fixed by renaming sql_logger.c to sql_logger.cc
Diffstat (limited to 'sql/CMakeLists.txt')
-rw-r--r--sql/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/sql/CMakeLists.txt b/sql/CMakeLists.txt
index 4eb2b2197ef..22c51f3ce23 100644
--- a/sql/CMakeLists.txt
+++ b/sql/CMakeLists.txt
@@ -85,7 +85,7 @@ SET (SQL_SOURCE
gcalc_slicescan.cc gcalc_tools.cc
threadpool_common.cc
../sql-common/mysql_async.c
- sql_logger.c
+ sql_logger.cc
${GEN_SOURCES}
${MYSYS_LIBWRAP_SOURCE}
)